Bug 834891 - ovirt-engine-backend [Direct Lun]: we can add stateless tag and run vm with direct lun
ovirt-engine-backend [Direct Lun]: we can add stateless tag and run vm with d...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.0
Assigned To: Tal Nisan
vvyazmin@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-24 11:26 EDT by Dafna Ron
Modified: 2016-02-10 11:59 EST (History)
12 users (show)

See Also:
Fixed In Version: SI17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:03:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (30.30 KB, application/x-xz)
2012-06-24 11:26 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-06-24 11:26:55 EDT
Created attachment 594015 [details]
log

Description of problem:

since no snapshot can be created for a direct lun, when a vm has only a direct lun we should fail to start it with stateless tag and when it has other regular disks as well as direct lun we should issue warning that the lun will not be stateless. 

Version-Release number of selected component (if applicable):

si6

How reproducible:

100%

Steps to Reproduce:
1. create a vm with direct lum
2. try to run it as stateless
3.
  
Actual results:

we are able to run the vm with no warnings. 

Expected results:

since no stateless snapshot is created we should fail the run of the vm as stateless with appropriate warning.  


Additional info: full log

2012-06-24 18:23:56,544 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand] (pool-3-thread-44) [63c16329] FINISH, CreateVDSCommand, log id: dba46da
2012-06-24 18:23:56,549 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-3-thread-44) [63c16329] IncreasePendingVms::CreateVmIncreasing vds orange-vdsd pending vcpu count, now 1. Vm: XP_OS
2012-06-24 18:23:56,681 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-3-thread-44) [63c16329] FINISH, CreateVmVDSCommand, return: WaitForLaunch, log id: 5a53c4b5
2012-06-24 18:24:00,345 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (QuartzScheduler_Worker-26) VM XP_OS ede8cac5-27e1-4d44-9e2d-2abbbac0ee5e moved from WaitForLaunch --> PoweringUp
2012-06-24 18:24:00,346 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FullListVdsCommand] (QuartzScheduler_Worker-26) START, FullListVdsCommand(vdsId = 43879c8a-b3bd-11e1-b071-001a4a169741, vds=null, vmIds=[ede8cac5-27e1-4d44-9e2d-2abbbac0ee5e]), log id: 1a0c69a7
2012-06-24 18:24:00,359 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.FullListVdsCommand] (QuartzScheduler_Worker-26) FINISH, FullListVdsCommand, return: [Lorg.ovirt.engine.core.vdsbroker.xmlrpc.XmlRpcStruct;@24ec604d, log id: 1a0c69a7
(END)
Comment 1 Andrew Cathrow 2012-06-24 11:49:31 EDT
I wonder if we w
Comment 2 Itamar Heim 2012-06-26 05:06:51 EDT
not sure if we should fail the run, or just print a warning to audit log (assuming there is another disk to be stateless).

use case:
I want to make sure my users are using stateless and not keeping anything on Disk1.
I want to attach a disk with the user profile, from an externally managed storage via a direct LUN.
Comment 3 Yaniv Kaul 2012-07-01 05:28:48 EDT
PM, decide what to do with this BZ.
Comment 4 Andrew Cathrow 2012-07-08 02:18:44 EDT
(In reply to comment #1)
> I wonder if we w

Looks like I lost some text there.

The use case is valid if there is more than one disk. 
Eg stateless system disk with a direct lun.

I'd suggest warning only.
Comment 5 Ayal Baron 2012-07-15 09:28:37 EDT
(In reply to comment #4)
> (In reply to comment #1)
> > I wonder if we w
> 
> Looks like I lost some text there.
> 
> The use case is valid if there is more than one disk. 
> Eg stateless system disk with a direct lun.
> 
> I'd suggest warning only.

Need to grey out the button if no "snappable" disks available, otherwise allow pressing it but in case there are disks which are not "snappable" issue a warning to the user.
Comment 6 Barak 2012-07-16 07:57:29 EDT
(In reply to comment #4)
> (In reply to comment #1)
> > I wonder if we w
> 
> Looks like I lost some text there.
> 
> The use case is valid if there is more than one disk. 
> Eg stateless system disk with a direct lun.
> 
> I'd suggest warning only.

- if it's a valid use case why warn ?

- should we fail with error if it's only one direct-lun disk?
Comment 7 Dafna Ron 2012-07-16 08:35:01 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > (In reply to comment #1)
> > > I wonder if we w
> > 
> > Looks like I lost some text there.
> > 
> > The use case is valid if there is more than one disk. 
> > Eg stateless system disk with a direct lun.
> > 
> > I'd suggest warning only.
> 
> - if it's a valid use case why warn ?

I would think that a warning is good solution here too since user might make possibly destructive changes not realizing that there is no rollback on the direct lun. 

> 
> - should we fail with error if it's only one direct-lun disk?

as a user I think that a warning would be enough here too. 
although changes may not be kept for the direct lun I might want to use a single vm for tests and not create a new one or remove the stateless tag while I test. 
so I think that a warning would be good here too - if user still wants to run the vm than let him.

and goes without saying but I'm of course not answering for Andrew :)
Comment 8 Tal Nisan 2012-07-16 09:15:15 EDT
WIP on that bug.
Comment 9 Tal Nisan 2012-07-16 10:12:26 EDT
http://gerrit.ovirt.org/#/c/6334/
Comment 10 Tal Nisan 2012-07-19 10:58:16 EDT
An audit log message will be displayed whenever the user is trying to run a VM as stateless which contains non snappable disks - "${VmName} was run as stateless with one or more of disks that do not allow snapshots (User:${UserName})."
Comment 11 Dafna Ron 2012-07-29 10:14:36 EDT
not verified since the warning only appears when the vm is run with one regular disk and one direct lun. 
if the vm is only run with direct lun no warning appears. 


with direct lun + regular disk: 

VM direct2 was run as stateless with one or more of disks that do not allow snapshots (User:admin@internal).

with direct lun only: 

VM direct2 was started by admin@internal (Host: orange-vdsd).
Comment 12 Haim 2012-08-03 09:23:42 EDT
moving back to assigned per C11. 
bug failed QE and cannot move to on_qa without any commit ID.
Comment 13 Ayal Baron 2012-08-08 08:39:00 EDT
Tal, need to make sure that same behaviour applies for live snapshot with non-snappable disks etc.
Comment 15 Allon Mureinik 2012-08-29 07:08:13 EDT
merged change id: I6c7421f45dfa75847482a7abd23ddb5feb7d6f9e
Comment 16 vvyazmin@redhat.com 2012-09-05 10:36:53 EDT
Verified on RHEVM 3.1 - SI17

RHEVM: rhevm-3.1.0-15.el6ev.noarch
VDSM: vdsm-4.9.6-32.0.el6_3.x86_64
LIBVIRT: libvirt-0.9.10-21.el6_3.4.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64
SANLOCK: sanlock-2.3-3.el6_3.x86_64

Warning appears, when the VM is run with one regular disk and one Direct LUN: 
VM vm-desk-02 was run as stateless with one or more of disks that do not allow snapshots (User:admin@internal).

Warning appears, when the VM is run with Direct LUN only:
VM vm-desk-04 was run as stateless with one or more of disks that do not allow snapshots (User:admin@internal).

Note You need to log in before you can comment on or make changes to this bug.