Bug 83491 - Screen corruption on Dell I8100 and I8200 with Geforce2 Go and Geforce4 440 Go
Screen corruption on Dell I8100 and I8200 with Geforce2 Go and Geforce4 440 Go
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-02-04 16:07 EST by Need Real Name
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-17 06:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-02-04 16:07:59 EST
Description of problem:

The Dell Inspirons have the possibility of seeing graphical and numerical
battery status info by pressing the Fn and F3 keys together. You can return
to X by pressing the Esc key.
With Phoebe1 and Phoebe2 this return to X results in screen corruption:
The screen seems to be split in 4 parts and these put together again in
a wrong position and the panel is drawn in the middle of the screen.
(It can be corrected by doing Ctrl-Alt-Fx (x=1,2,...) and the Ctrl-Alt-F7).
Both i8100 (GeForce2 Go) and i8200 (GeForce4 440 Go) are using the 'nv'
driver from XFree.
I have also seen the problem when the machine has not been in use for some
time and the monitor enters 'sleep state'. On return to X I see the same 
screen corruption

Version-Release number of selected component (if applicable):

XFree86-4.2.99.3-20030118.3 in Phoebe2 with all updates (04-02-2003).

How reproducible:

Always.


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Need Real Name 2003-02-04 16:14:46 EST
I forgot to add that I did not see this behaviour with RH-8.0 and the 'nvidia'
driver and the XFree86's available for RH-8.0.
If I remember correctly I also did not see it with the 'vesa' driver. I cannot
check because I have no Inspiron with RH-8.0 now.
Comment 2 Mike A. Harris 2003-02-05 09:51:22 EST
This type of problem can only really be fixed by the video driver maintainer,
whom has access to both the hardware, and the technical specifications for
Nvidia video hardware.

Nvidia does not permit/allow access to their hardware specifications,
so nobody but Nvidia can resolve issues like this.

Please report this problem upstream to xfree86@xfree86.org and when
the upstream driver maintainer fixes the problem, it can be considered
for integration into Red Hat Linux.
Comment 3 Mike A. Harris 2003-07-17 06:19:02 EDT
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:

    http://bugs.xfree86.org

Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.


Note You need to log in before you can comment on or make changes to this bug.