Bug 835049 - Add "mkrdns" to Fedora packages
Add "mkrdns" to Fedora packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 06:57 EDT by Nico Kadel-Garcia
Modified: 2012-07-21 06:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 11:22:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC file for mkrdns (1.15 KB, text/plain)
2012-06-25 06:57 EDT, Nico Kadel-Garcia
no flags Details

  None (edit)
Description Nico Kadel-Garcia 2012-06-25 06:57:49 EDT
Created attachment 594158 [details]
SPEC file for mkrdns

Description of problem:
    mkrdns is not in Fedora

Version-Release number of selected component (if applicable):
    mkrdns 3.3

How reproducible:
    yum list | grep -i mkrdns


Additional info:
    mkrdns is a very useful tool for generating, and verifiying, reverse DNS tables for BIND. It's fairly old, it's stable, and is incredibly useful with GUI based or source controlled BIND configurations to auto-update the reverse DNS, and to correctly manage multiple A records for the same IP address.
    I recently included its use in my presentation at Subversion Day, "SVNday" in Berlin, and would like to get it RPM bundled in Fedora and EPEL for future use. It's available at Repoforge, but I've had difficulty getting clients to accept non-RHEL or EPEL components in working environments.
Comment 1 Nico Kadel-Garcia 2012-06-25 06:59:53 EDT
Also, for reference, the .spec file is the one from Repoforge: I actually submitted that one to them, and they understandably reset the "Packager" and "Vendor", which you'd need to reset for EPEL inclusion.
Comment 2 Bill Nottingham 2012-06-25 13:00:25 EDT
See http://fedoraproject.org/wiki/Join#OS_Developer for information on getting packages into Fedora and maintaining them. I'm moving this to "Package Review".
Comment 3 Susi Lehtola 2012-07-19 11:22:32 EDT
This is not a bug.

Add mkrdns to the Fedora wishlist.
Comment 4 Susi Lehtola 2012-07-19 11:23:04 EDT
... or as instructed by Bill in comment #2, join the Fedora maintainers and submit your package for review.

Note You need to log in before you can comment on or make changes to this bug.