Bug 835107 - Unable to eject optical media using "Device notifier"
Unable to eject optical media using "Device notifier"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kdelibs (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: alpha
: 7.0
Assigned To: Lukáš Tinkl
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 10:47 EDT by Martin
Modified: 2015-07-13 13:36 EDT (History)
4 users (show)

See Also:
Fixed In Version: kdelibs-4.8.3-6.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 11:28:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of udisksctl monitor (1.64 KB, text/x-log)
2012-06-25 10:47 EDT, Martin
no flags Details
Backtrace kded4 (22.67 KB, text/plain)
2012-06-25 10:50 EDT, Martin
no flags Details
Screenshot with bug on RHEL 7 (27.19 KB, image/png)
2012-06-25 10:51 EDT, Martin
no flags Details
Screenshot with correct icon/state from Fedora 17 (30.52 KB, image/png)
2012-06-25 10:59 EDT, Martin
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 294344 None None None 2012-06-26 11:40:03 EDT

  None (edit)
Description Martin 2012-06-25 10:47:12 EDT
Created attachment 594199 [details]
Log of udisksctl monitor

Description of problem:
Unable to eject optical media using "Device notifier".

Version-Release number of selected component (if applicable):
kdelibs-4.8.3-4.el7

How reproducible:
always

Steps to Reproduce:
1. Insert optical media
2. Wait for "Device notifier" notification and select "Open with file manager"
3. Close file manager
4. Try to eject media using "Device notifier".
  
Actual results:
"Device notifier" doesn't show "eject/unmount icon", but "mount" instead. It seems to be unaware of current media state.

Expected results:
"Device notifier" shows "eject/unmount icon" and can safely remove media.

Additional info:
See screenshots, first is with bug on RHEL 7, second is correct icon/state on Fedora 17.

1) I can correctly eject media using Dolphin.
2) I can eject media using optical drive button, but /dev/sr0 stays mounted.
Comment 1 Martin 2012-06-25 10:50:27 EDT
Created attachment 594200 [details]
Backtrace kded4

added GDB backtrace
Comment 2 Martin 2012-06-25 10:51:51 EDT
Created attachment 594201 [details]
Screenshot with bug on RHEL 7
Comment 3 Martin 2012-06-25 10:59:10 EDT
Created attachment 594206 [details]
Screenshot with correct icon/state from Fedora 17
Comment 4 Martin 2012-06-25 11:34:39 EDT
See related bug:
https://bugzilla.redhat.com/show_bug.cgi?id=835120
Comment 6 Martin 2012-06-27 07:38:32 EDT
kdelibs-4.8.3-5.el7 verification failed
Comment 7 Lukáš Tinkl 2012-06-27 13:15:21 EDT
Should be fixed in kdelibs-4.8.3-6.el7
Comment 8 Martin 2012-06-28 05:59:14 EDT
kdelibs-4.8.3-6.el7 fixes the bug

Note You need to log in before you can comment on or make changes to this bug.