Bug 835288 - csprocessor does not replace new topic notation with topic id on push
csprocessor does not replace new topic notation with topic id on push
Status: CLOSED CANTFIX
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 16:53 EDT by Stephen Gordon
Modified: 2013-04-26 01:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.24.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-26 01:01:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Content Specification (15.53 KB, application/octet-stream)
2012-06-25 21:57 EDT, Stephen Gordon
no flags Details

  None (edit)
Comment 2 Lee Newson 2012-06-25 18:31:24 EDT
Some info please? eg The content spec that failed, what version you were using, where there any abnormalities when pushing, etc...
Comment 3 Stephen Gordon 2012-06-25 21:53:29 EDT
All of these details, and the content specification, are marked private (that is why your comment is c#2). You might want to get your bugzilla permissions checked out to make sure they are correct ;). In the meantime I will email the details to you.
Comment 4 Stephen Gordon 2012-06-25 21:57:31 EDT
Created attachment 594329 [details]
Content Specification
Comment 5 Lee Newson 2012-06-25 22:20:31 EDT
Cheers, thanks Steve and I'll didn't even notice my comment was number so thanks for the heads up.
Comment 6 Lee Newson 2012-06-26 02:26:22 EDT
Fixed will attempt to release a version today. If not I'll get it done first thing tomorrow morning.

Cause:

Under certain circumstances the input string was returned for the replace function for new topics. The issue was due to a regular expression and returning the wrong item.

Consequence:

New topics weren't being created in the pushed content specification.

Fix:

Fix the regular expression and the return statement to return the updated output string.
Comment 7 Lee Newson 2012-06-26 03:41:59 EDT
Released as part of 0.24.9
Comment 8 Stephen Gordon 2012-06-27 16:15:22 EDT
Running cspclient-0.24.10-1.noarch and I tried to add a few new topics this way today and encountered the same behaviour (topics created in skynet, not reflected in the local specification). Has this been tested?

I'm adding topics to the tail end of content spec with ID 9054, I'm wondering if the length/complexity of the spec is still throwing off your regex?
Comment 9 Lee Newson 2012-06-27 18:35:05 EDT
Will test against a live server backup. I was testing against our developer server which has a different REST interface but I didn't see this as an issue.
Comment 10 Lee Newson 2012-06-27 19:40:33 EDT
I've tested it using the revision's that I found for topic 9054 against version 0.24.10 of the CSP and wasn't able to replicate it after multiple attempts. 

For a start, I'll add a warning message, if after post processing any new topics are found. That will at least stop duplicate topics being added. As for your issue I'll keep trying to see if I can replicate it.
Comment 12 Lee Newson 2013-04-26 01:01:49 EDT
Closing this as I couldn't replicate it and it has been reported happening again. If it does happen again, please re-open the bug.
Comment 13 Lee Newson 2013-04-26 01:02:59 EDT
Oops "has" should have been "hasn't" in the previous comment.

Note You need to log in before you can comment on or make changes to this bug.