Bug 835355 - system_admin.js has hardcoded URL of /change_system_admin
system_admin.js has hardcoded URL of /change_system_admin
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 0.9.2
: ---
Assigned To: Raymond Mancy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 00:42 EDT by Dan Callaghan
Modified: 2014-12-07 20:12 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 04:06:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-06-26 00:42:07 EDT
When the app is mounted at /bkr tests fail like this:

======================================================================
ERROR: test_add_system_group_admin_privs (bkr.inttest.server.selenium.test_system_groups.TestSystemGroups)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/bkr/inttest/server/selenium/test_system_groups.py", line 69, in test_add_system_group_admin_privs
    WebDriverWait(b, 5).until(lambda driver: 'Yes' in driver.find_element_by_xpath('//span[@id="admin_group_%s"]' % self.group.group_id).text)
  File "/usr/lib64/python2.6/site-packages/selenium/webdriver/support/wait.py", line 56, in until
    raise TimeoutException()
TimeoutException: Message: None 

======================================================================
ERROR: test_remove_system_group_admin_privs (bkr.inttest.server.selenium.test_system_groups.TestSystemGroups)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/bkr/inttest/server/selenium/test_system_groups.py", line 51, in test_remove_system_group_admin_privs
    b.find_element_by_link_text('(Remove)').click()
  File "/usr/lib64/python2.6/site-packages/selenium/webdriver/remote/webdriver.py", line 234, in find_element_by_link_text
    return self.find_element(by=By.LINK_TEXT, value=link_text)
  File "/usr/lib64/python2.6/site-packages/selenium/webdriver/remote/webdriver.py", line 645, in find_element
    {'using': by, 'value': value})['value']
  File "/usr/lib64/python2.6/site-packages/selenium/webdriver/remote/webdriver.py", line 153, in execute
    self.error_handler.check_response(response)
  File "/usr/lib64/python2.6/site-packages/selenium/webdriver/remote/errorhandler.py", line 147, in check_response
    raise exception_class(message, screen, stacktrace)
NoSuchElementException: Message: u'Unable to locate element: {"method":"link text","selector":"(Remove)"}' 

because system_admin.js is pointing at /change_system_admin when it should be /bkr/change_system_admin. We need to tg.url() it somehow.
Comment 2 Raymond Mancy 2012-07-31 01:22:00 EDT
http://gerrit.beaker-project.org/#/c/1250/
Comment 3 Raymond Mancy 2012-08-01 08:58:03 EDT
Sorry, this is the real one
http://gerrit.beaker-project.org/#/c/1265/
Comment 6 Dan Callaghan 2012-08-09 04:06:40 EDT
Beaker 0.9.2 has been released.

Note You need to log in before you can comment on or make changes to this bug.