Bug 835373 - console logs are not cleared when manually provisioning
console logs are not cleared when manually provisioning
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
urgent Severity unspecified (vote)
: 0.9.1
: ---
Assigned To: Dan Callaghan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 01:19 EDT by Dan Callaghan
Modified: 2012-07-19 20:39 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 20:39:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2012-06-26 01:19:10 EDT
As of commit 92dcec89 the clearing of console logs is tied to the watchdog log monitoring, rather than using the command queue. This fixed a race between the logs being cleared and the watchdog starting to monitor the log -- but it means the logs are never cleared when manually provisioning.

One possibility we have discussed is to put clear_logs back into the command queue, and change things so that the watchdog kill_time is initialised as a callback from the reboot command instead of when the recipe is started by beakerd. This will fix the race (because the watchdog won't be picked up until kill_time is not NULL, by which point the logs will have been cleared) and it will also allow us to clear logs for manual provisions.
Comment 1 Dan Callaghan 2012-07-11 19:53:55 EDT
(In reply to comment #0)
> As of commit 92dcec89 the clearing of console logs is tied to the watchdog
> log monitoring, rather than using the command queue. This fixed a race
> between the logs being cleared and the watchdog starting to monitor the log
> -- but it means the logs are never cleared when manually provisioning.

This is quite a serious bug because of the following situation:

* User manually reserves a system
* User plays around, triggers a panic somehow
* User returns the system, but log is *not* cleared
* Scheduler picks the system for a job
* Watchdog sees panic in old console log and aborts the job
Comment 2 Dan Callaghan 2012-07-11 23:06:56 EDT
On Gerrit: http://gerrit.beaker-project.org/1204
Comment 5 Dan Callaghan 2012-07-19 20:39:02 EDT
Beaker 0.9.1 has been released.

Note You need to log in before you can comment on or make changes to this bug.