Bug 835630 - Bad value for ROOSTER_MAX_UNHIBERNATE in PowerManagementSubnetManager
Bad value for ROOSTER_MAX_UNHIBERNATE in PowerManagementSubnetManager
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-base-db (Show other bugs)
Development
Unspecified Unspecified
medium Severity medium
: 2.2
: ---
Assigned To: Robert Rati
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 12:13 EDT by Lubos Trilety
Modified: 2012-09-25 04:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: condor-wallaby-base-db-1.22-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 14:26:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2012-06-26 12:13:57 EDT
Description of problem:
When I upgrade db from 2.0 snapshot it is not completely the same as the loaded default snapshot for 2.2 It differs in value for parameter ROOSTER_MAX_UNHIBERNATE in PowerManagementSubnetManager feature.
The problem is that the value was "0" and in Grid 2.2 it's corrected to 0. But this correction is not part of db patches.

Version-Release number of selected component (if applicable):
condor-wallaby-base-db-1.22-4

How reproducible:
100%

Steps to Reproduce:
1. load old version of db snapshot
2. upgrade db
3. compare upgraded db with default snapshot
  
Actual results:
there's some discrepancy
the feature PowerManagementSubnetManager has different value for ROOSTER_MAX_UNHIBERNATE, it's 0 in default snapshot whilst in upgraded db it's "0".

Expected results:
no differences were found

Additional info:
Comment 1 Robert Rati 2012-06-27 15:07:01 EDT
MAXJOBRETIREMENTTIME, ROOSTER_MAX_UNHIBERNATE, SCHEDD_PREEMPTION_RANK all had their values changed on their respective features from "0" (a value) to 0 (use default) in the db and patch files.  The values have been rest to the original "0".

On all params, the default parameter value was sane but the change on the features should not have occurred.

Fixed upstream on master.
Comment 3 Lubos Trilety 2012-07-20 07:52:00 EDT
Tested with:
condor-wallaby-base-db-1.22-5

The value for MAXJOBRETIREMENTTIME, ROOSTER_MAX_UNHIBERNATE, SCHEDD_PREEMPTION_RANK is changed back to "0".

>>> verified

Note You need to log in before you can comment on or make changes to this bug.