Bug 835707 - "\n" in text displays and broken links in Conductor GUI on Fedora 17
"\n" in text displays and broken links in Conductor GUI on Fedora 17
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.1.0
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Imre Farkas
Giulio Fidente
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 17:56 EDT by Ronelle Landy
Modified: 2016-09-20 01:02 EDT (History)
7 users (show)

See Also:
Fixed In Version: aeolus-conductor-0.13.16-1.el6cf
Doc Type: Bug Fix
Doc Text:
Cloud Engine's Web UI incorrectly rendered rows for some views. This bug fix corrects the rendering. Rows now display without fault.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 10:12:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Users tab (240.66 KB, image/png)
2012-06-26 17:56 EDT, Ronelle Landy
no flags Details
Provider Accounts (217.93 KB, image/png)
2012-06-26 17:59 EDT, Ronelle Landy
no flags Details
Extra "\conductor" in link (63.69 KB, image/png)
2012-06-26 18:01 EDT, Ronelle Landy
no flags Details

  None (edit)
Description Ronelle Landy 2012-06-26 17:56:48 EDT
Created attachment 594610 [details]
Users tab

Description of problem:

When running conductor on Fedora 17 (aeolus-conductor-0.10.2-1.fc17.noarch), users see "\n\n" attached to text displayed, extra '\conductors\' in links, misaligned tables and usernames showsn as "\1".

See attached screenshots.


Steps to Reproduce:
1. Install conductor on a F17 machine using testing-updates
2. run aeolus-configure -p admin
3. run aeolus-configure -p amock,ec2,vsphere
4. run aeolus-restart-services
5. log in to conductor as admin
6. click around the GUI and view pages, links as captured in the screenshots attached
  

rpms installed:

>> rpm -qa |grep aeolus
aeolus-conductor-doc-0.10.2-1.fc17.noarch
rubygem-aeolus-cli-0.5.0-1.fc17.noarch
aeolus-conductor-0.10.2-1.fc17.noarch
aeolus-conductor-daemons-0.10.2-1.fc17.noarch
aeolus-configure-2.6.0-1.fc17.noarch
rubygem-aeolus-image-0.5.0-1.fc17.noarch
aeolus-all-0.10.2-1.fc17.noarch

>> rpm -qa |grep deltacloud
deltacloud-core-rackspace-1.0.0-3.fc17.noarch
deltacloud-core-rimuhosting-1.0.0-3.fc17.noarch
deltacloud-core-gogrid-1.0.0-3.fc17.noarch
deltacloud-core-1.0.0-3.fc17.noarch
deltacloud-core-openstack-1.0.0-3.fc17.noarch
deltacloud-core-sbc-1.0.0-3.fc17.noarch
deltacloud-core-rhevm-1.0.0-3.fc17.noarch
deltacloud-core-google-1.0.0-3.fc17.noarch
deltacloud-core-fgcp-1.0.0-3.fc17.noarch
deltacloud-core-ec2-1.0.0-3.fc17.noarch
deltacloud-core-all-1.0.0-3.fc17.noarch
rubygem-deltacloud-client-0.5.0-3.fc17.noarch
deltacloud-core-doc-1.0.0-3.fc17.noarch
deltacloud-core-vsphere-1.0.0-3.fc17.noarch
deltacloud-core-opennebula-1.0.0-3.fc17.noarch
deltacloud-core-eucalyptus-1.0.0-3.fc17.noarch
Comment 1 Ronelle Landy 2012-06-26 17:59:21 EDT
Created attachment 594616 [details]
Provider Accounts
Comment 2 Ronelle Landy 2012-06-26 18:01:25 EDT
Created attachment 594617 [details]
Extra "\conductor" in link
Comment 3 Steve Linabery 2012-06-26 19:25:47 EDT
FWIW, I cannot reproduce any of the above with rpms built off 'master' branch of conductor and aeolus-configure.

I will retry with builds in f17 updates/updates-testing and see if I can reproduce it again. I was seeing the '\n' behaviour earlier on f17 install.
Comment 4 Justin Clift 2012-06-27 10:01:19 EDT
Someone mentioned on IRC that this patch (already in master), is probably the right fix:

  https://fedorahosted.org/pipermail/aeolus-devel/2012-June/010728.html
Comment 7 Mike Orazi 2012-09-06 11:22:36 EDT
This is not a product bug.
Comment 10 Giulio Fidente 2012-10-03 09:22:15 EDT
as per Dave's suggestion, this is not happening on RHEL using aeolus-conductor-0.13.16-1.el6cf so I'm moving the bug to VERIFIED state.

if the problem is still happening on Fedora, it should be reported against the Fedora component aeolus-configure, not the Cloud Engine product from Red Hat
Comment 12 errata-xmlrpc 2012-12-04 10:12:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.