Bug 835732 - F16 install fails
F16 install fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-26 21:18 EDT by Andrew
Modified: 2012-09-05 09:46 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 09:46:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew 2012-06-26 21:18:49 EDT
Description of problem:

With the install dvd I couldn't get the graphical display to work correctly but could use the tab key and a little trial and error to go through the install. Kernel options like resolution= and xdriver= were completely ignored by the installer and I still got the same size screen with the buttons off screen.

The install would hang during the network setup process where it would identify my lan card as a p4p1 controller with a mac address of all F's. Not being able to change the controller means you can't go forward and clicking the Back button exits the installer.

Repeated identical results using the text mode install as well.

I downloaded the Fedora 16 Live CD iso (605 mb) and installed it onto a USB stick and successfully booted the computer using that. (hooray I thought) It also went through the install process without a flaw. (think I'm on a winner here) System boots fine, and fast, but there's no dvd drive, my realtek lan is still a p4p1 controller with a mac address of all F's, and the terminal won't let me sudo or use su. I can look but I can't touch.


Version-Release number of selected component (if applicable):

Fedora 16 install DVD using kernel-PAE-3.1.0-7.fc16.i686


How reproducible:

Very - does the same thing on two other computers with new intel chipsets.

Steps to Reproduce:

1. build a new computer with motherboard chipset intel B75

2. insert F16 install DVD

3. press enter key at appropriate moment
  
Actual results:

unusable fedora system

Expected results:

0 to google in 17 seconds.

Additional info:

All computers are also running WinXP and all components are running without fault. Install media has been checked and has also been used on 4 other computers including a Mac Pro and the system runs flawlessly.

The computers I'm having trouble with aren't anything special, just cheap motherboards with intel chipsets, built-in intel graphics and realtek sound and lan:

Gigabytes - GA-B75M-D3H

Asrock - H61M/U3S3

Results listed above were for the Gigabytes motherboards, with the Asrock board installer crashes while trying to load Xserver. Text mode also fails to start.

Whith both motherboards if the installer DVD is left in the drive when you reboot then motherboard goes into a continuous cycle of rebooting until you pull the power plug.

With the Asrock motherboard trying to boot from a Fedora Live-USB just sends the motherboard into a continuous cycle of rebooting.

I'm making the assumption that it's just a lack of driver modules for newer chipsets as the fedora installs and runs so beautifully on the other machines. It's a shame really, when I helped people choose these motherboards I deliberately steered them towards intel chipsets because they always had such great support under linux.

I'm halfway through upgrading a full install (using that same install DVD) on an external USB drive in the hope that if I can find and install the correct chipset drivers I should be able to boot these machines from the usb, if that works then all I need to do is find out how to use kickstart and livecd to make my own install DVD.

Cheers,

Andrew.
Comment 1 Justin M. Forbes 2012-06-27 15:07:06 EDT
Does the Fedora 17 installer work for you? Part of the problem is the installer is kernel locked, so F16 is using a very old kernel.
Comment 2 Andrew 2012-06-27 18:20:49 EDT
Hi Justin,

No, haven't tried F17 yet, I live in a remote area and we only have satelite internet access. It's slow enough to start with but now I've used all my gigs for the month I'm getting about 8K per second, will try F17 after the 30th this month.

The reason I stuck with F16 is because I bought the disks, installer and repository. This meant I could set up a machine with a good range of software without having to go on the net.

Kudos to the entire Fedora team by the way, when this baby does install it's the fastest and easiest to use that I've ever seen.

Is my idea with the external drive a bad one?

Cheers,

Andrew.
Comment 3 Andrew 2012-06-27 18:24:54 EDT
Hi Justin,

No, haven't tried F17 yet, I live in a remote area and we only have satelite internet access. It's slow enough to start with but now I've used all my gigs for the month I'm getting about 8K per second, will try F17 after the 30th this month.

The reason I stuck with F16 is because I bought the disks, installer and repository. This meant I could set up a machine with a good range of software without having to go on the net.

Kudos to the entire Fedora team by the way, when this baby does install it's the fastest and easiest to use that I've ever seen.

Is my idea with the external drive a bad one?

Cheers,

Andrew.
Comment 4 Andrew 2012-06-27 18:47:27 EDT
Hi Justin,

No, haven't tried F17 yet, I live in a remote area and we only have satelite internet access. It's slow enough to start with but now I've used all my gigs for the month I'm getting about 8K per second, will try F17 after the 30th this month.

The reason I stuck with F16 is because I bought the disks, installer and repository. This meant I could set up a machine with a good range of software without having to go on the net.

Kudos to the entire Fedora team by the way, when this baby does install it's the fastest and easiest to use that I've ever seen.

Is my idea with the external drive a bad one?

Cheers,

Andrew.
Comment 5 Andrew 2012-07-05 20:14:42 EDT
Hi Justin,

I downloaded and tried the F17 Live on the computers I was having trouble with.

The Gigabytes motherboards loaded and ran straight away, everything normal as far as I can tell but I still have the same trouble with the Asrock motherboard.

I've tried playing around with different BIOS settings to see if it made any difference but no joy. Is there a list somewhere of recommended bios settings for booting Fedora? That would be handy.

Cheers,

Andrew.
Comment 6 Josh Boyer 2012-09-05 09:46:10 EDT
(In reply to comment #5)
> I've tried playing around with different BIOS settings to see if it made any
> difference but no joy. Is there a list somewhere of recommended bios
> settings for booting Fedora? That would be handy.

No, there is not.

Fedora doesn't update install media after it has been released.  Due to that there is nothing we can do in F16/F17.  If you are interested in getting this fixed in Fedora, we would appreciate testing with the F18 Alpha once it is released.  We will still have time to fix it for the final F18 release.

If so, please test with F18 and open a bug against that version with the relevant details.

Note You need to log in before you can comment on or make changes to this bug.