Bug 835815 - RFE: gnome-boxes should have a browse capability
RFE: gnome-boxes should have a browse capability
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-boxes (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 03:57 EDT by cornel panceac
Modified: 2012-06-27 11:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 05:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2012-06-27 03:57:46 EDT
Description of problem: Request for Enhancement

gnome-boxes should have browsing capability, to open install isos or to import existing virtual machines. 

also, gnome-boxes should *not* depend on tracker since tracker should be uninstalled anyway.

Version-Release number of selected component (if applicable):
gnome-boxes-3.4.3-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marc-Andre Lureau 2012-06-27 05:45:09 EDT
(In reply to comment #0)
> gnome-boxes should have browsing capability, to open install isos or to
> import existing virtual machines. 

You can browse filesystem by using the "Select a File" option in wizard source selection page.

Existing VM from other libvirt instances can be added by providing libvirt URI in wizard source "Enter URL".

The import of existing VM not managed by libvirt is not implemented yet:

https://bugzilla.gnome.org/show_bug.cgi?id=677691

> also, gnome-boxes should *not* depend on tracker since tracker should be
> uninstalled anyway.

Tracker is a gnome dependency, it is being used by more and more projects. There is no plan to make it optionnal. However, if you prepare a clean patch, we might accept it if it not too intrusive.

(if you have issues with tracker, you should open a bug to tracker)

Please use gnome bugzilla for rfe and upstream bugs.
https://bugzilla.gnome.org/
Comment 2 Christophe Fergeau 2012-06-27 05:49:34 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > also, gnome-boxes should *not* depend on tracker since tracker should be
> > uninstalled anyway.
> 
> Tracker is a gnome dependency, it is being used by more and more projects.
> There is no plan to make it optionnal. However, if you prepare a clean
> patch, we might accept it if it not too intrusive.
> 

boxes works fine for me without tracker running, but the RPM package has a dependency on libtracker-sparql-0.14.so.0()(64bit).
Comment 3 cornel panceac 2012-06-27 09:21:22 EDT
yes, one problem i have with tracker is that uninstalling it took gnome-boxes with it.
Comment 4 Marc-Andre Lureau 2012-06-27 11:10:54 EDT
(In reply to comment #2)
> boxes works fine for me without tracker running, but the RPM package has a
> dependency on libtracker-sparql-0.14.so.0()(64bit).

(In reply to comment #3)
> yes, one problem i have with tracker is that uninstalling it took
> gnome-boxes with it.

That's because there is library dependency, and that library depends on tracker. Perhaps libtracker-sparql-0.14.so.0 can be made not to require tracker? Probably worth opening a bug for tracker package to ask there

Note You need to log in before you can comment on or make changes to this bug.