Bug 835817 - default assignee is not copied from default tester upon test run creation anymore
default assignee is not copied from default tester upon test run creation any...
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.7.0
All Unspecified
high Severity high
: ---
: ---
Assigned To: June Zhang
tools-bugs
: Regression
Depends On:
Blocks: 593666
  Show dependency treegraph
 
Reported: 2012-06-27 04:04 EDT by Miroslav Franc
Modified: 2016-01-31 21:27 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 05:26:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Franc 2012-06-27 04:04:51 EDT
Description of problem:
When somebody create new test run assignee of each test case is the author of the run no matter who is the default tester of each test case. This is huge problem for us, because we have hard time filtering who is reposponsible for what.


Version-Release number of selected component (if applicable):
3.7.0


How reproducible:
every time


Steps to Reproduce:
1. pick some test plan containing test cases with various default testers
2. create run
3. watch assignee of each test case


Actual results:
assignee of the test case is set based on author of the run


Expected results:
assignee of the test case is set based on default tester of the test case
Comment 1 Miroslav Franc 2012-06-28 06:43:22 EDT
example: https://tcms.engineering.redhat.com/run/41901/
Comment 2 Petr Šplíchal 2012-07-11 10:34:12 EDT
Hi, any update about this unpleasant regression?
Comment 3 yawei Li 2012-07-13 06:15:37 EDT
There is a field "default tester" in creating test run page, which is set to the creator by default.
You can update "default tester" field to set the test case runs to the same assignee. And if it is blank, the test case's default tester is the assignee. 

In your example, you haven't changed the "default tester", so all of test-case-run's assignees are you.
Comment 4 yawei Li 2012-08-24 05:26:02 EDT
Close it. if still have issue, please reopen it.

Note You need to log in before you can comment on or make changes to this bug.