Bug 835820 - Error message of threaddump for scalable application
Error message of threaddump for scalable application
Status: CLOSED UPSTREAM
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Ram Ranganathan
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 04:13 EDT by Rony Gong
Modified: 2015-05-14 21:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 19:22:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-06-27 04:13:25 EDT
Description of problem:



Version-Release number of selected component (if applicable):
devenv_1864

How reproducible:
always

Steps to Reproduce:
1.create a scalable application jbossas-7
2.access this app page after it created.
3.do threaddump
[root@localhost ~]# rhc-ctl-app  -c threaddump -a qsjboss
Password: 

RESULT:
Success
The thread dump file will be available via: rhc app tail -a e1cf0c88b3 -f e1cf0c88b3/jbossas-7/standalone/tmp/e1cf0c88b3.log -o '-n 250'
Success

The thread dump file will be available via: rhc app tail -a qsjboss -f qsjboss/jbossas-7/standalone/tmp/qsjboss.log -o '-n 250'

4. then I run the first tail file command

Actual results:
[root@localhost ~]#  rhc app tail -a e1cf0c88b3 -f e1cf0c88b3/jbossas-7/standalone/tmp/e1cf0c88b3.log -o '-n 250'
Password: 


Could not find app 'e1cf0c88b3'.  Please run rhc-domain-info to get a list
of your current running applications


Expected results:

I suggest should show the first tail file message:
The thread dump file will be available via: rhc app tail -a e1cf0c88b3 -f e1cf0c88b3/jbossas-7/standalone/tmp/e1cf0c88b3.log -o '-n 250'
Success

since we couldn't use this command to get tail file.





Additional info:
Comment 1 Rony Gong 2012-06-27 04:17:24 EDT
sorry, 
Expected results:

I suggest shouldn't show the first tail file message:
The thread dump file will be available via: rhc app tail -a e1cf0c88b3 -f e1cf0c88b3/jbossas-7/standalone/tmp/e1cf0c88b3.log -o '-n 250'
Success

since we couldn't use this command to get tail file.
Comment 2 Rony Gong 2012-06-27 05:03:23 EDT
this error message can be found in scalable jbossas-7, jbosseap-6.0, ruby-1.8, ruby-1.9
Comment 3 Rob Millner 2012-07-02 22:15:49 EDT
We don't currently offer direct access to secondary gears in a scalable application so logs and thread dumps are missing.
Comment 4 Ram Ranganathan 2012-07-20 19:22:02 EDT
Closing this out as there is a user story US2501 associated for this as well as tidy + tail_logs + port_forward  (+ potentially snapshot/restore appcrud).

Note You need to log in before you can comment on or make changes to this bug.