Bug 835974 - [abrt] autojump-20-1.fc17: utf_8.py:16:decode:UnicodeDecodeError: 'utf8' codec can't decode byte 0xa5 in position 16: invalid start byte
[abrt] autojump-20-1.fc17: utf_8.py:16:decode:UnicodeDecodeError: 'utf8' code...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autojump (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thibault North
Fedora Extras Quality Assurance
abrt_hash:8f7cb19b81b9d361b60c4a05489...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 13:34 EDT by Hedayat Vatankhah
Modified: 2013-01-12 18:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-12 18:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedayat Vatankhah 2012-06-27 13:34:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        python /usr/bin/autojump -a '/home/hedayat/\xd9\x83\xa5\xd9\x83\xa8\xd8\xb3\xdb\x83\xac\xd9\x82\xdb\x83\xac/\xd9\xbe\xd8\xa7\xd9\xbe/\xd9\x83\xa5\xd9\x83\xa7\xd8\xb1\xd9\x83\xa6\xd9\x83\xa8\xd8\xb4/new'
comment:        cd out of an already deleted directory!
executable:     /usr/bin/autojump
kernel:         3.4.3-1.fc17.x86_64
time:           چهارشنبه ۲۷ ژوئن ۱۲، ۲۲:۰۲:۲۷
uid:            1000
username:       hedayat

backtrace:
:utf_8.py:16:decode:UnicodeDecodeError: 'utf8' codec can't decode byte 0xa5 in position 16: invalid start byte
:
:Traceback (most recent call last):
:  File "/usr/bin/autojump", line 329, in <module>
:    success=shell_utility()
:  File "/usr/bin/autojump", line 243, in shell_utility
:    dicadd(path_dict, decode(args.add))
:  File "/usr/bin/autojump", line 69, in decode
:    return text.decode(encoding,errors)
:  File "/usr/lib64/python2.7/encodings/utf_8.py", line 16, in decode
:    return codecs.utf_8_decode(input, errors, True)
:UnicodeDecodeError: 'utf8' codec can't decode byte 0xa5 in position 16: invalid start byte
:
:Local variables in innermost frame:
:input: '/home/hedayat/\xd9\x83\xa5\xd9\x83\xa8\xd8\xb3\xdb\x83\xac\xd9\x82\xdb\x83\xac/\xd9\xbe\xd8\xa7\xd9\xbe/\xd9\x83\xa5\xd9\x83\xa7\xd8\xb1\xd9\x83\xa6\xd9\x83\xa8\xd8\xb4/new'
:errors: 'strict'
Comment 1 Thibault North 2012-12-12 12:30:46 EST
Please try the last autojump version from updates-testing :
https://admin.fedoraproject.org/updates/autojump-21.1.2-2.fc17?_csrf_token=1175ddbfe795bfa9cc5b4b32ff00bcacaafd9bf1
Thanks!
Comment 2 Hedayat Vatankhah 2012-12-12 14:19:50 EST
Thanks, it seems to be fixed. :)
Comment 3 Thibault North 2013-01-12 18:50:14 EST
Thanks for the report :)

Note You need to log in before you can comment on or make changes to this bug.