Bug 836027 - Rhevm provider is not created after running "aeolus-configure -p rhevm"
Rhevm provider is not created after running "aeolus-configure -p rhevm"
Status: CLOSED DUPLICATE of bug 838118
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 18:10 EDT by Ronelle Landy
Modified: 2012-07-26 10:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-26 10:16:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronelle Landy 2012-06-27 18:10:29 EDT
Description of problem:

I installed aeolus conductor (aeolus-conductor-0.10.4-1.fc17) with deltacloud-core-1.0.0-4 on Fedora 17. I copied across the rhevm-configure file from the test area (included in a comment below) and then ran >> aeolus-configure -p <provider> and >> aeolus-restart-services.

mock, ec2, vsphere providers were created but not rhevm (see the output from commands copied below)


Steps to Reproduce:
1. Install aeolus-conductor on F17 (with deltacloud-core 1.0.0-4)
2. Copy rhevm_configure fil eto /stc/aeolus-configure/nodes
3. Run aeolus-configure -p rhevm
4. See not provider is added

==== Note: ===============

When I first saw the missing provider, I thought that the rbovirt gem was missing. Tried 
>> gem install rbovirt
and
>> yum install rubygem-rbovirt

Both the above installed something but it didn't help with the provider creation/adding.

deltacloud could start a server pointing at rhevm (so that driver was recognized by deltacloud server)

===============================
  
Output from aeolus-configure is copied below:

**************

>>  aeolus-configure -p rhevm
Launching aeolus configuration recipe...
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/usr/share/ruby/vendor_ruby/puppet/provider/service/freebsd.rb:8: warning: class variable access from toplevel
/usr/share/ruby/vendor_ruby/puppet/provider/service/freebsd.rb:9: warning: class variable access from toplevel
/usr/share/ruby/vendor_ruby/puppet/provider/service/freebsd.rb:10: warning: class variable access from toplevel
/usr/share/ruby/vendor_ruby/puppet/provider/service/bsd.rb:12: warning: class variable access from toplevel
warning: Dynamic lookup of $temp_admin_login at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm/instance.pp:46 is deprecated.  Support will be removed in Puppet 2.8.  Use a fully-qualified variable name (e.g., $classname::variable) or parameterized classes.
warning: Dynamic lookup of $temp_admin_login at /usr/share/aeolus-configure/modules/aeolus/manifests/profiles/rhevm/instance.pp:47 is deprecated.  Support will be removed in Puppet 2.8.  Use a fully-qualified variable name (e.g., $classname::variable) or parameterized classes.
notice: the RHEV NFS export is on the correct storage domain and has type 'export' => true
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Aeolus::Rhevm::Validate[RHEV NFS export validation for default]/Notify[RHEV NFS export validation for default]/message: defined 'message' as 'the RHEV NFS export is on the correct storage domain and has type 'export' => true'
notice: /Stage[main]/Apache/Exec[permit-http-networking]/returns: executed successfully
notice: /Stage[main]/Aeolus::Deltacloud::Core/Exec[deltacloud-core-startup-wait]/returns: executed successfully
notice: /File[/usr/share/aeolus-conductor/config/initializers/secret_token.rb]/content: content changed '{md5}dec32a6245fbff3e0c6f38d6302b63b6' to '{md5}bb700541efaab0580784e60b6109a794'
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: conductor already exists
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Create::Db[create_aeolus_database]/Exec[create_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor/Aeolus::Rails::Migrate::Db[migrate_aeolus_database]/Exec[migrate_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[create_temp_admin]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[create_temp_admin]/returns: User temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e registered
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[create_temp_admin]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[grant_temp_admin_privs]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[grant_temp_admin_privs]/returns: Granting administrator privileges for temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e...
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[grant_temp_admin_privs]/returns: executed successfully
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Login[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Web_request[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e-conductor-login]/post: post changed '' to 'https://localhost/conductor/user_session'
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Login[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[decrement_login_counter]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Login[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[decrement_login_counter]/returns: Login counter for user temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e updated
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Login[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[decrement_login_counter]/returns: executed successfully
err: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Profiles::Rhevm::Instance[default]/Aeolus::Conductor::Provider[rhevm-default]/Web_request[provider-rhevm-default]/post: change from  to https://localhost/conductor/providers failed: An exception was raised when invoking web request: Invalid expression: ["//img[@alt='Notices']"]
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Hwp[small-x86_64]/Web_request[hwp-small-x86_64]/post: post changed '' to 'https://localhost/conductor/hardware_profiles'
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Logout[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Web_request[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e-conductor-logout]: Dependency Web_request[provider-rhevm-default] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Logout[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Web_request[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e-conductor-logout]: Skipping because of failed dependencies
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[destroy_temp_admin]:

====== See error below ============

 Dependency Web_request[provider-rhevm-default] has failures: true
warning: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Conductor::Destroy_temp_admin[temporary-administrative-user-de3e0a8cf9f9c39b1ee9007c5dce59398de42dca7188620e]/Exec[destroy_temp_admin]: Skipping because of failed dependencies

===================================

notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns:                                  Dload  Upload   Total   Spent    Left  Speed
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Create_bucket[aeolus]/Exec[create-bu  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
notice: /Stage[main]/Aeolus::Profiles::Rhevm/Aeolus::Create_bucket[aeolus]/Exec[create-bucket-aeolus]/returns: executed successfully
notice: Finished catalog run in 282.64 seconds


*************

>> aeolus-image list --providers

Name                   Type        Target Reference     
------------------     -------     ----------------     
mock                   mock                             
ec2-ap-northeast-1     ec2         ap-northeast-1       
ec2-us-west-1          ec2         us-west-1            
ec2-eu-west-1          ec2         eu-west-1            
ec2-us-east-1          ec2         us-east-1            
ec2-ap-southeast-1     ec2         ap-southeast-1       
ec2-us-west-2          ec2         us-west-2            
vsphere-default        vsphere     <ip of vsphere server>        
ec2-sa-east-1          ec2         sa-east-1 


Additional info:

rpms tested:

>>rpm -qa |grep aeolus
aeolus-conductor-0.10.4-1.fc17.noarch
aeolus-configure-2.6.0-1.fc17.noarch
aeolus-conductor-doc-0.10.4-1.fc17.noarch
rubygem-aeolus-image-0.5.0-1.fc17.noarch
aeolus-all-0.10.4-1.fc17.noarch
aeolus-conductor-devel-0.10.4-1.fc17.noarch
rubygem-aeolus-cli-0.5.0-1.fc17.noarch
aeolus-conductor-daemons-0.10.4-1.fc17.noarch

>> rpm -qa |grep deltacloud
rubygem-deltacloud-client-0.5.0-3.fc17.noarch
deltacloud-core-1.0.0-4.fc17.noarch
deltacloud-core-ec2-1.0.0-4.fc17.noarch
deltacloud-core-rhevm-1.0.0-4.fc17.noarch
deltacloud-core-vsphere-1.0.0-4.fc17.noarch
deltacloud-core-doc-1.0.0-4.fc17.noarch
Comment 2 Dave Johnson 2012-07-26 10:16:04 EDT

*** This bug has been marked as a duplicate of bug 838118 ***

Note You need to log in before you can comment on or make changes to this bug.