This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836120 - warning messages appears when run "rhc-idler -u" from instance
warning messages appears when run "rhc-idler -u" from instance
Status: CLOSED CANTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 03:13 EDT by Meng Bo
Modified: 2015-05-14 18:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-16 15:04:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2012-06-28 03:13:11 EDT
Description of problem:
rhc-idler -u <uuid> to idle app from instance, will get some warning messages.

[root@ip-10-73-25-67 runtime]# rhc-idler -u e101259045404724abe6fb8099d8c9bf
[Thu Jun 28 03:01:08 2012] [warn] module passenger_module is already loaded, skipping
[Thu Jun 28 03:01:08 2012] [warn] The Alias directive in /etc/httpd/conf.d/stickshift/e101259045404724abe6fb8099d8c9bf_bmengdev_ruby1s/000000_haproxy.conf at line 2 will probably never match because it overlaps an earlier Alias.
[Thu Jun 28 03:01:08 2012] [warn] The Alias directive in /etc/httpd/conf.d/stickshift/e101259045404724abe6fb8099d8c9bf_bmengdev_ruby1s/000000_haproxy.conf at line 2 will probably never match because it overlaps an earlier Alias.
Stopping e101259045404724abe6fb8099d8c9bf...
    ruby1s_ctl.sh                                          [  OK  ]


Version-Release number of selected component (if applicable):
devenv_1868

How reproducible:
always

Steps to Reproduce:
1.rhc-idler -u <app_uuid>
2.
3.
  
Actual results:
Some warning messages aopears.

Expected results:
Should not have such warnings.

Additional info:
App can be idled beside the warnings, so make the bug as low severity.
Comment 1 Ram Ranganathan 2012-07-18 14:48:43 EDT
Logging some stuff I noticed -- a couple of reasons this happens: 
1. haproxy cartridge has an Alias for health and idling an app takes over the whole
    namespace.
2. The new ruby193 scl added a  mod_passenger for ruby-1.9 along w/ a new 
    /etc/httpd/conf.d/ruby193-passenger.conf which causes the 
    duplicate passenger already loaded messages to show up. Maybe should change
    the file to load the module if not loaded or the ruby193-mod_passenger rpm.''
Comment 2 Jhon Honce 2013-04-16 15:04:31 EDT
Code refactored.

Note You need to log in before you can comment on or make changes to this bug.