Bug 836184 - Jenkins build always shows "waiting for build to schedule" in stage
Jenkins build always shows "waiting for build to schedule" in stage
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 05:52 EDT by Jianwei Hou
Modified: 2015-05-14 18:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins log (92.00 KB, text/x-log)
2012-06-28 06:20 EDT, Jianwei Hou
no flags Details
More research from stage (7.42 KB, text/plain)
2012-06-28 15:01 EDT, Dan Mace
no flags Details

  None (edit)
Description Jianwei Hou 2012-06-28 05:52:56 EDT
Description of problem:
on stage:
jenkins build an app, and the output show it is Waiting for build to schedule

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.create an app(eg jbossas,php) with jenkins-client-1.4 embedded
2.make some change in the app's repo
3.git commit && git push
4.it always shows waiting for build to schedule, no matter how long waited
  
Actual results:
Counting objects: 7, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 360 bytes, done.
Total 4 (delta 2), reused 0 (delta 0)
remote: Executing Jenkins build.
remote: 
remote: You can track your build at https://jkss-jhou.stg.rhcloud.com/job/p1-build
remote: 
remote: Waiting for build to schedule................................................................................................................................................................................................................................................................................................................................................................................


please find jenkins.log in the attachments.

Expected results:
should git push successfully

Additional info:
Comment 1 Jianwei Hou 2012-06-28 06:18:58 EDT
stage version 2.0.13
Comment 2 Jianwei Hou 2012-06-28 06:20:36 EDT
Created attachment 594989 [details]
jenkins log

please find logs in the attachments
Comment 3 Dan Mace 2012-06-28 15:01:01 EDT
Created attachment 595109 [details]
More research from stage

I'm adding some more research from stage detailing the various exceptions presented at each step of the test scenario. Looks like the Jenkins plugin is having trouble communicating with the broker via the legacy API to provision a builder node.
Comment 4 Bill DeCoste 2012-06-29 12:19:20 EDT
This is working fine on a devenv but stage for some reason is getting socket timeouts when Jenkins is trying to hit the broker:
Caused by: java.net.SocketTimeoutException: connect timed out
when trying to hit
https://stg.openshift.redhat.com/broker/userinfo
Comment 5 Bill DeCoste 2012-06-29 13:05:40 EDT
Can we get the broker log?
Comment 6 Dan Mace 2012-07-03 12:33:31 EDT
We've watched the broker logs in stage while Jenkins attempts to provision the node on a 1 minute interval. For each failed request from Jenkins, there is a corresponding log in the broker:

ActionController::RoutingError (No route matches "/")

This is the only related server side log which has been found so far.
Comment 7 Dan Mace 2012-07-03 20:16:53 EDT
There was a connectivity issue isolated to stage preventing jenkins from communicating with the broker. The issue was caused by a stale /etc/hosts entry for the stage host, causing the jenkins http client to be unable to resolve stage. Stage has been corrected, and Jenkins now functions properly.
Comment 8 Jianwei Hou 2012-07-03 22:50:57 EDT
verified on statge 2.0.13

1.create jenkins app
2.create app with jenkins-client enabled
3.make some change in app's repo an git push

jenkins build works well now.

Note You need to log in before you can comment on or make changes to this bug.