Bug 836230 - Test case failure: /CoreOS/ypserv/singlehost
Test case failure: /CoreOS/ypserv/singlehost
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.0
Unspecified Linux
low Severity low
: rc
: ---
Assigned To: Steve Dickson
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 08:40 EDT by Karel Volný
Modified: 2012-11-14 10:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 10:19:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2012-06-28 08:40:03 EDT
Filed from caserun https://tcms.engineering.redhat.com/run/41363/#caserun_1236697

Version-Release number of selected component (if applicable):
RHEL-7.0-20120614.n.1

Steps to Reproduce: 
run the test

Actual results: 
rpcbind.service - RPC bind service
	  Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; enabled)
	  Active: active (running) since Sat, 16 Jun 2012 07:31:44 -0400; 14h ago
	Main PID: 977 (rpcbind)
	  CGroup: name=systemd:/system/rpcbind.service
		  └ 977 /sbin/rpcbind -w


Warning: Unit file changed on disk, 'systemctl --system daemon-reload' recommended.
Warning: Unit file of created job changed on disk, 'systemctl --system daemon-reload' recommended.
Warning: Unit file of created job changed on disk, 'systemctl --system daemon-reload' recommended.
Job failed. See system journal and 'systemctl status' for details.
:: [21:38:10] :: [ ERROR   ] :: rlServiceStart: Starting service rpcbind failed

Expected results:
(no errors starting the service)

Additional information:
this seems to happen only in the beaker run - trying service start manually on an ITP system works without any problem
Comment 1 Honza Horak 2012-07-11 03:44:03 EDT
I don't think there is any problem in ypserv, since *rpcbind* is the service not starting, so re-assigning to rpcbind.

Just a note: it shouldn't be necessary to explicitly start rpcbind in the test, because it should be done by systemd, according to requirements set in ypbind/ypserv unit files. However, this failure probably means some issues in rpcbind.
Comment 2 Honza Horak 2012-07-11 04:24:52 EDT
It's weird, that another test (/CoreOS/ypserv/Sanity/initscipts-ypserv), which includes the same command "rlServiceStart rpcbind" succeeds. I'd say something has to be different in test case environment.
Comment 3 Karel Volný 2012-07-11 09:17:57 EDT
(In reply to comment #1)
> I don't think there is any problem in ypserv, since *rpcbind* is the service
> not starting, so re-assigning to rpcbind.

oops, sorry, it got pre-filled by TCMS

> Just a note: it shouldn't be necessary to explicitly start rpcbind in the
> test, because it should be done by systemd, according to requirements set in
> ypbind/ypserv unit files. However, this failure probably means some issues
> in rpcbind.

thanks for the info, I've updated the test

http://pkgs.devel.redhat.com/cgit/tests/ypserv/commit/?id=3a5776654b0bc05b619c745347f93fd28e997d87

(In reply to comment #2)
> It's weird, that another test (/CoreOS/ypserv/Sanity/initscipts-ypserv),
> which includes the same command "rlServiceStart rpcbind" succeeds. I'd say
> something has to be different in test case environment.

I'd say ... let's wait and see if this could be reproduced in the next RHEL7 tier run ...
Comment 6 Karel Volný 2012-11-14 10:19:47 EST
seems the problem is gone ...
https://tcms.engineering.redhat.com/run/50413/#caserun_1767556

Note You need to log in before you can comment on or make changes to this bug.