Bug 836257 - [abrt] mercurial-1.9.3-1.fc16: gettext.py:406:ugettext:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 77: ordinal not in range(128)
[abrt] mercurial-1.9.3-1.fc16: gettext.py:406:ugettext:UnicodeDecodeError: 'a...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Neal Becker
Fedora Extras Quality Assurance
abrt_hash:422165ebdfed65f1eb6432f5485...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 09:50 EDT by Gustavo Maciel Dias Vieira
Modified: 2012-06-28 16:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-28 15:59:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustavo Maciel Dias Vieira 2012-06-28 09:50:38 EDT
libreport version: 2.0.10
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/bin/hg pull -u ../treplica
comment:        The problem happens when running pull with the -u option and there are changes to be merged afterwards (creates two heads). If I pull, and then update, there is no problem. After the exception, I could merge without any apparent problem.
executable:     /usr/bin/hg
kernel:         3.4.2-1.fc16.x86_64
time:           Qui 28 Jun 2012 10:23:53 BRT

backtrace:
:gettext.py:406:ugettext:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 77: ordinal not in range(128)
:
:Traceback (most recent call last):
:  File "/usr/bin/hg", line 38, in <module>
:    mercurial.dispatch.run()
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 27, in run
:    sys.exit(dispatch(request(sys.argv[1:])))
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 64, in dispatch
:    return _runcatch(req)
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 87, in _runcatch
:    return _dispatch(req)
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 688, in _dispatch
:    cmdpats, cmdoptions)
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 463, in runcommand
:    ret = _runcommand(ui, options, cmd, d)
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 742, in _runcommand
:    return checkargs()
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 696, in checkargs
:    return cmdfunc()
:  File "/usr/lib64/python2.7/site-packages/mercurial/dispatch.py", line 685, in <lambda>
:    d = lambda: util.checksignature(func)(ui, *args, **cmdoptions)
:  File "/usr/lib64/python2.7/site-packages/mercurial/util.py", line 389, in check
:    return func(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/mercurial/extensions.py", line 137, in wrap
:    util.checksignature(origfn), *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/mercurial/util.py", line 389, in check
:    return func(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/hgext/rebase.py", line 610, in pullrebase
:    orig(ui, repo, *args, **opts)
:  File "/usr/lib64/python2.7/site-packages/mercurial/util.py", line 389, in check
:    return func(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/mercurial/commands.py", line 3801, in pull
:    ret = postincoming(ui, repo, modheads, opts.get('update'), checkout)
:  File "/usr/lib64/python2.7/site-packages/mercurial/commands.py", line 3730, in postincoming
:    ui.warn(_("not updating: %s\n" % str(inst)))
:  File "/usr/lib64/python2.7/site-packages/mercurial/i18n.py", line 42, in gettext
:    u = u'\n\n'.join([p and t.ugettext(p) or '' for p in paragraphs])
:  File "/usr/lib64/python2.7/gettext.py", line 406, in ugettext
:    return unicode(message)
:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 77: ordinal not in range(128)
:
:Local variables in innermost frame:
:message: 'not updating: atravessa ramos (mescle os ramos ou use update --check para for\xc3\xa7ar a atualiza\xc3\xa7\xc3\xa3o)\n'
:tmsg: <object object at 0x7f68a86c9230>
:self: <gettext.GNUTranslations instance at 0x7f68a18acb48>
:missing: <object object at 0x7f68a86c9230>
Comment 1 Mads Kiilerich 2012-06-28 11:21:54 EDT
/usr/lib64/python2.7/site-packages/mercurial/commands.py line 3730 should not be
    ui.warn(_("not updating: %s\n" % str(inst)))
but
    ui.warn(_("not updating: %s\n") % str(inst))
It is has been fixed in later releases.

You can work around the problem with
  LANG=C hg pull ...
or just edit the file as root.
Comment 2 Neal Becker 2012-06-28 15:59:28 EDT
I assume this is OK to close then?
Comment 3 Gustavo Maciel Dias Vieira 2012-06-28 16:05:15 EDT
Will an update be issued?

If not, this will be broken in F16 until it EOLs. I don't known the QA workflow for this, but I guess it is best to leave it open until it is fixed or F16 EOLs, or maybe close it with WONTFIX.
Comment 4 Neal Becker 2012-06-28 16:46:44 EDT
I'm no expert, but I think your suggestion is correct, to close with WONTFIX.  The newer upstreams hg 2.0+ are not going to be back ported to F16, because that would break other things (tortoisehg).

Note You need to log in before you can comment on or make changes to this bug.