Bug 836402 - can't install specific version of kernel or kernel-devel if newer version is already installed
can't install specific version of kernel or kernel-devel if newer version is ...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 836401 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 20:28 EDT by Andre Robatino
Modified: 2016-12-20 07:14 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 07:14:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2012-06-28 20:28:25 EDT
Description of problem:
If several versions of a package, such as kernel or kernel-devel, are installed, and I need to reinstall one of them, it's prevented unless it's the newest version. It complains that a newer version is already installed. This would make sense if it was a package that could only have one version installed. Same problem if I need to install an older version.

Version-Release number of selected component (if applicable):
yum-3.4.3-29.fc18.noarch

How reproducible:
always
Comment 1 Andre Robatino 2012-06-28 20:30:31 EDT
*** Bug 836401 has been marked as a duplicate of this bug. ***
Comment 2 James Antill 2012-06-29 14:13:04 EDT
 Can you show some output of this happening, because AFAICS it works.
 Also, if this is just rawhide, there is only one version available in rawhide. So maybe that's your problem?
Comment 3 Andre Robatino 2012-06-29 14:44:24 EDT
I grab older versions from Koji and then attempt to locally (re)install. Today's grub2 update broke my Rawhide (I can only boot from rescue mode) and I can't reproduce the problem that way. I'll provide output when things are back to normal.
Comment 4 Andre Robatino 2012-06-30 14:10:01 EDT
[root@localhost ~]# rpm -q kernel-devel
kernel-devel-3.5.0-0.rc4.git0.1.fc18.x86_64
kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64
kernel-devel-3.5.0-0.rc4.git4.1.fc18.x86_64
[root@localhost ~]# yum reinstall ./kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64.rpm
Loaded plugins: downloadonly, langpacks, presto, refresh-packagekit, security
Examining ./kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64.rpm: kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64
Resolving Dependencies
--> Running transaction check
---> Package kernel-devel.x86_64 0:3.5.0-0.rc4.git3.1.fc18 will be installed
---> Package kernel-devel.x86_64 0:3.5.0-0.rc4.git3.1.fc18 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package      Arch   Version
                            Repository                                     Size
================================================================================
Removing:
 kernel-devel x86_64 3.5.0-0.rc4.git3.1.fc18
                            @/kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64  28 M
Reinstalling:
 kernel-devel x86_64 3.5.0-0.rc4.git3.1.fc18
                            /kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64   28 M

Transaction Summary
================================================================================
Remove     1 Package
Reinstall  1 Package

Total size: 28 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test


Transaction Check Error:
  package kernel-devel-3.5.0-0.rc4.git4.1.fc18.x86_64 (which is newer than kernel-devel-3.5.0-0.rc4.git3.1.fc18.x86_64) is already installed

Error Summary
-------------

[root@localhost ~]#
Comment 5 Fedora End Of Life 2013-04-03 12:50:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 6 Fedora End Of Life 2015-01-09 12:13:28 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Jan Kurik 2015-07-15 11:06:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 23 development cycle.
Changing version to '23'.

(As we did not run this process for some time, it could affect also pre-Fedora 23 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 23 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora23
Comment 8 Fedora End Of Life 2016-11-24 05:41:08 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2016-12-20 07:14:32 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.