Bug 836412 - DrKonqi don't install debuginfo packages , when we click on install debug symbols
DrKonqi don't install debuginfo packages , when we click on install debug sym...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-runtime (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 21:55 EDT by Sergio Monteiro Basto
Modified: 2012-07-01 00:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-01 00:31:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full script (2.64 KB, text/plain)
2012-06-29 20:49 EDT, Rex Dieter
no flags Details
diff to illustrate differences (931 bytes, patch)
2012-06-29 20:50 EDT, Rex Dieter
no flags Details | Diff

  None (edit)
Description Sergio Monteiro Basto 2012-06-28 21:55:07 EDT
Description of problem:
I got some crashes with gwenview , but can't report it because when try install debug packages , ask for root password , prompt debuginfo-install usage close window without install debuginfos 


Version-Release number of selected component (if applicable):
kde-runtime-4.8.3-1.fc17.x86_64

How reproducible:
crash kwin , with gwenview

Expected results:

report bugs
Comment 1 Rex Dieter 2012-06-29 20:49:02 EDT
So, I've a local patch to /usr/libexec/kde4/installdbgsymbols.sh that does a few things:
* use pkexec instead of su
* add 'set -x' and some 'sleep' calls to help see what's going on
Comment 2 Rex Dieter 2012-06-29 20:49:38 EDT
Created attachment 595393 [details]
full script
Comment 3 Rex Dieter 2012-06-29 20:50:15 EDT
Created attachment 595394 [details]
diff to illustrate differences
Comment 4 Sergio Monteiro Basto 2012-07-01 00:31:53 EDT
Is working with kde-runtime-4.8.4-2.fc17.x86_64 .

Thanks

Note You need to log in before you can comment on or make changes to this bug.