Bug 836423 - Publican 3.0 creates tabs labelled "UNUSED" for unversioned content
Publican 3.0 creates tabs labelled "UNUSED" for unversioned content
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 00:03 EDT by Ruediger Landmann
Modified: 2014-10-14 00:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:10:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ruediger Landmann 2012-06-29 00:03:17 EDT
Description of problem:

When we use the web_version_label: UNUSED parameter to indicate that documentation is not specific to any one particular release of a product, Publican 3.0 creates a tab labelled "UNUSED" on the product navigation page. 

Worse, if different documents were created with different product versions and were had web_version_label: UNUSED set, Publican 3.0 creates multiple "UNUSED" tabs.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
100%

Steps to Reproduce:
1. Set web_version_label: UNUSED on a book, build it, and install it on a Publican-generated website
2. set web_version_label: UNUSED on a book with the same product but a different product version, build it, and install it on a Publican-generated website
3. navigate to the product page
  
Actual results:
Two tabs labelled "UNUSED", each with one book

Expected results:
Books that are not version-specific should appear on the version tab for each version of that product.
Comment 1 David O'Brien 2012-07-31 20:34:09 EDT
Verified this problem against OpenShift books, which don't use web labels.

Maybe we could do some sort of check to see if the "web_version_label" actually existed in publican.cfg and then create (or not) the Version tab based on that. That way instead of:

Product Documentation > OpenShift > UNUSED > $book_name

we could see the following:

Product Documentation > OpenShift > $book_name

Not sure what to do about the "UNUSED" box in the top right; does it do anything?
Comment 2 Joshua Wulf 2012-08-10 02:35:26 EDT
It would make sense that unversioned books need some identifying label. Since the web_version_label is now passed through to the Publican website as a literal string value, you could set web_version_label to "All Versions".

It would rely on books with the same string value being rendered in the same version tab.
Comment 3 Stephen Gordon 2012-08-10 10:12:15 EDT
(In reply to comment #1)
> Product Documentation > OpenShift > $book_name
> 
> Not sure what to do about the "UNUSED" box in the top right; does it do
> anything?

Based on Rudi's comment above yours ("Books that are not version-specific should appear on the version tab for each version of that product.") it seems we aren't going to get that functionality back.

Does anyone know what item in the Changes file this change (handling web_version_label as a string literal) was listed under? I couldn't see it.
Comment 4 Jeff Fearn 2012-08-12 20:36:51 EDT
(In reply to comment #3)
> Does anyone know what item in the Changes file this change (handling
> web_version_label as a string literal) was listed under? I couldn't see it.

web_version_label has always been a string literal, web_style_1 has logic to adjust the html style in the nav toc. This logic simply doesn't work on web_style 2.
Comment 6 Ruediger Landmann 2014-10-14 00:10:04 EDT
We're waaaay past this now :)

Note You need to log in before you can comment on or make changes to this bug.