Bug 836485 - rsyslogd segfaults when this config file is used
rsyslogd segfaults when this config file is used
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rsyslog (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Tomas Heinrich
Jiri Jaburek
:
Depends On: 1040036
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 04:34 EDT by Milos Malik
Modified: 2014-06-18 03:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: rsyslog-7.4.7-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:30:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-06-29 04:34:39 EDT
Description of problem:
I'm not sure which of the last 9 lines in the config file causes the segfault, but one of them is definitely the culprit.

Version-Release number of selected component (if applicable):
rsyslog-relp-5.8.10-1.el7.x86_64
rsyslog-gnutls-5.8.10-1.el7.x86_64
rsyslog-5.8.10-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# grep -v -e '^#' -e '^$' /etc/rsyslog.conf 
$ModLoad imuxsock # provides support for local system logging (e.g. via logger command)
$ModLoad imklog   # provides kernel logging support (previously done by rklogd)
$ActionFileDefaultTemplate RSYSLOG_TraditionalFileFormat
$IncludeConfig /etc/rsyslog.d/*.conf
*.info;mail.none;authpriv.none;cron.none                /var/log/messages
authpriv.*                                              /var/log/secure
mail.*                                                  -/var/log/maillog
cron.*                                                  /var/log/cron
*.emerg                                                 *
uucp,news.crit                                          /var/log/spooler
local7.*                                                /var/log/boot.log
$DefaultNetstreamDriver gtls
$MaxOpenFiles 2100
$WorkDirectory /var/spool/rsyslog
$ActionQueueType LinkedList
$ActionQueueFileName srvrfwd
$ActionResumeRetryCount -1
$ActionQueueSaveOnShutdown on
$ActionQueueMaxDiskSpace 1g
*.* @@127.0.0.1
# service rsyslog restart
Redirecting to /bin/systemctl  restart rsyslog.service
# service rsyslog status
Redirecting to /bin/systemctl  status rsyslog.service
rsyslog.service - System Logging Service
	  Loaded: loaded (/usr/lib/systemd/system/rsyslog.service; enabled)
	  Active: failed (Result: signal) since Fri, 29 Jun 2012 10:27:42 +0200; 2s ago
	 Process: 32134 ExecStart=/sbin/rsyslogd -n $SYSLOGD_OPTIONS (code=killed, signal=SEGV)
	 Process: 32131 ExecStartPre=/bin/systemctl stop systemd-kmsg-syslogd.service (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/rsyslog.service

#
  
Actual results:
* rsyslogd is not running

Expected results:
* rsyslogd is running
Comment 2 Milos Malik 2012-07-04 07:59:21 EDT
Following line was missing in the confi file:

$DefaultNetstreamDriverCAFile /etc/pki/rsyslog/ca.pem

When this line is present the service does not segfault anymore.
Comment 3 Milos Malik 2012-07-04 08:01:50 EDT
I'm going to correct the automated test.
Comment 5 Tomas Heinrich 2013-12-22 10:11:46 EST
This was fixed in the upstream version 7.4.5. The current version in el7 is 7.4.2 but a rebase is planned which would resolve this issue.
Comment 11 Ludek Smid 2014-06-13 07:30:29 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.