Bug 836491 - Sub package zarafa-dagent does not work with php53
Sub package zarafa-dagent does not work with php53
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: zarafa (Show other bugs)
el5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 05:11 EDT by Roland Wolters
Modified: 2012-12-04 07:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 07:10:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2012-06-29 05:11:18 EDT
Description of problem:
Zarafa is supposed to work with php53 packages.

Version-Release number of selected component (if applicable):
zarafa-dagent = 7.0.7-1.el5

How reproducible:
Install php53, than try to install zarafa.

Steps to Reproduce:
1. yum install php53
2. yum install zarafa
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package zarafa.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: zarafa-dagent = 7.0.7-1.el5 for package: zarafa
--> Running transaction check
---> Package zarafa-dagent.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: php-mapi = 7.0.7-1.el5 for package: zarafa-dagent
--> Running transaction check
---> Package php-mapi.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mapi
--> Running transaction check
---> Package php-common.x86_64 0:5.1.6-39.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-13.el5_8.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest


Expected results:
It should just install.

Additional info:
There was a similar issue regarding zarafa-webaccess which was solved by introducing php53-mapi and the spec file part:
# Bug: php53 from RHEL 5 does not provide php (#717158)
%if 0%{?rhel} == 5
Requires:           mod_php >= 4.3
%else
Requires:           php >= 4.3
%endif

So maybe something similar could be a solution for the zarafa-dagent packages as well?
Comment 1 Robert Scheck 2012-06-29 05:31:17 EDT
Are you sure that the combination is really like you describe it, because:

Package php53-mapi-7.0.7-1.el5 provides: php-mapi = 7.0.7-1.el5,
  php53-mapi = 7.0.7-1.el5

Package zarafa-dagent-7.0.7-1.el5 requires: php-mapi = 7.0.7-1.el5

According to that, the dependency should be satisfied already, shouldn't it?
Comment 2 Roland Wolters 2012-06-30 14:03:28 EDT
Well, according to the yum output mentioned above the problem seems to be php53-common, and not php53-mapi. php*mapi just pulls in the wrong php version:


--> Processing Dependency: php-api = 20041225 for package: php-mapi
--> Running transaction check
---> Package php-common.x86_64 0:5.1.6-39.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
Comment 3 Robert Scheck 2012-06-30 19:13:52 EDT
The cause for this is already that php-mapi not php53-mapi is selected by
yum here. Because php-mapi requires php-api = 20041225, while php53-mapi
requires php(api) = 20090626.

So can you please try "yum install php53-mapi" then "yum install zarafa"?
Comment 4 Roland Wolters 2012-07-02 18:01:24 EDT
Well, doesn't work for me...

# yum clean all

# rpm -qa|grep php
php53-5.3.3-13.el5_8
php53-common-5.3.3-13.el5_8
php53-mapi-7.0.6-1.el5
php53-cli-5.3.3-13.el5_8

# yum install zarafa
[...]
Resolving Dependencies
--> Running transaction check
---> Package zarafa.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: zarafa-dagent = 7.0.7-1.el5 for package: zarafa
--> Running transaction check
---> Package zarafa-dagent.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: php-mapi = 7.0.7-1.el5 for package: zarafa-dagent
--> Running transaction check
---> Package php-mapi.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: php-api = 20041225 for package: php-mapi
--> Running transaction check
---> Package php-common.x86_64 0:5.1.6-39.el5_8 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-13.el5_8.x86_64 from installed has depsolving problems
  --> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Even "yum install zarafa --exclude=php-mapi" does not work:

# yum install zarafa --exclude=php-mapi
[..]
Resolving Dependencies
--> Running transaction check
---> Package zarafa.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: zarafa-dagent = 7.0.7-1.el5 for package: zarafa
--> Running transaction check
---> Package zarafa-dagent.x86_64 0:7.0.7-1.el5 set to be updated
--> Processing Dependency: php-mapi = 7.0.7-1.el5 for package: zarafa-dagent
--> Finished Dependency Resolution
zarafa-dagent-7.0.7-1.el5.x86_64 from epel has depsolving problems
  --> Missing Dependency: php-mapi = 7.0.7-1.el5 is needed by package zarafa-dagent-7.0.7-1.el5.x86_64 (epel)
Error: Missing Dependency: php-mapi = 7.0.7-1.el5 is needed by package zarafa-dagent-7.0.7-1.el5.x86_64 (epel)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 5 Roland Wolters 2012-12-04 07:10:09 EST
I replaced the EL version with a newer one (6), so the problem is no longer relevant for me. I will close the bug.

Note You need to log in before you can comment on or make changes to this bug.