Bug 836509 - system.entitlements_valid reports Valid when the overall system entitlement certificate status is red
system.entitlements_valid reports Valid when the overall system entitlement c...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-29 06:22 EDT by Shwetha Kallesh
Modified: 2013-01-10 04:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-17 09:13:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-06-29 06:22:04 EDT
Description of problem:

system.entitlements_valid reports Valid when the overall system entitlement certificate status is red

Version-Release number of selected component (if applicable):
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-firstboot-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-migration-data-1.11.2.1-1.git.8.87961f3.el5
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5


How reproducible:


Steps to Reproduce:
1.[root@dhcp201-196 ~]# subscription-manager facts --list | grep entitlements_valid
system.entitlements_valid: valid

2.[root@dhcp201-196 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Awesome OS for S390 Bits
Product ID:           	100000000000060
Version:              	3.11
Arch:                 	s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Basic
Product ID:           	1144
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Product ID:           	100000000000011
Version:              	3.11
Arch:                 	x86_64,i686,ia64,ppc,ppc64,s390x,s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Workstation Bits
Product ID:           	27060
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Red Hat Enterprise Linux High Availability (for RHEL Server)
Product ID:           	83
Version:              	5.8
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Bits
Product ID:           	1
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Management Bits
Product ID:           	37069
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Large File Support Bits
Product ID:           	37068
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Modifier Bits
Product ID:           	37080
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Clustering Bits
Product ID:           	37065
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Shared Storage Bits
Product ID:           	37067
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Server Bits
Product ID:           	37060
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Premium Architecture Bits
Product ID:           	37062
Version:              	6.1
Arch:                 	ppc64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for ia64 Bits
Product ID:           	100000000000006
Version:              	3.11
Arch:                 	ia64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for i686 Bits
Product ID:           	100000000000005
Version:              	3.11
Arch:                 	i686
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86_64 Bits
Product ID:           	100000000000002
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for ppc64 Bits
Product ID:           	100000000000003
Version:              	3.11
Arch:                 	ppc64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for S390X Bits
Product ID:           	100000000000000
Version:              	3.11
Arch:                 	s390x
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for i386 Bits
Product ID:           	100000000000001
Version:              	3.11
Arch:                 	i386
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86 Bits
Product ID:           	100000000000020
Version:              	8.6
Arch:                 	x86
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Red Hat Enterprise Linux Resilient Storage (for RHEL Server)
Product ID:           	90
Version:              	5.8
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Shared File System Bits
Product ID:           	88888
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Multiplier Product Bits
Product ID:           	917571
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Load Balancing Bits
Product ID:           	37070
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

3.
  
Actual results:


Expected results:
system.entitlements_valid: invalid

Additional info:
Comment 1 Bryan Kearney 2012-08-16 12:34:01 EDT
What did you do before this?

This is what I am seeing off of latest:

[root@bkearney ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: invalid
[root@bkearney ~]# subscription-manager facts --list --installed
Usage: subscription-manager facts [OPTIONS]

subscription-manager: error: no such option: --installed
[root@bkearney ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	6.3
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

[root@bkearney ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Awesome OS for S390 Bits
Product ID:           	100000000000060
Version:              	3.11
Arch:                 	s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Basic
Product ID:           	1144
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86_64/i686/ia64/ppc/ppc64/s390x/s390 Bits
Product ID:           	100000000000011
Version:              	3.11
Arch:                 	x86_64,i686,ia64,ppc,ppc64,s390x,s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Workstation Bits
Product ID:           	27060
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	6.3
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Bits
Product ID:           	1
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Management Bits
Product ID:           	37069
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Large File Support Bits
Product ID:           	37068
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Modifier Bits
Product ID:           	37080
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Clustering Bits
Product ID:           	37065
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Shared Storage Bits
Product ID:           	37067
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Server Bits
Product ID:           	37060
Version:              	6.1
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Premium Architecture Bits
Product ID:           	37062
Version:              	6.1
Arch:                 	ppc64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for ia64 Bits
Product ID:           	100000000000006
Version:              	3.11
Arch:                 	ia64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for i686 Bits
Product ID:           	100000000000005
Version:              	3.11
Arch:                 	i686
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86_64 Bits
Product ID:           	100000000000002
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for ppc64 Bits
Product ID:           	100000000000003
Version:              	3.11
Arch:                 	ppc64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for S390X Bits
Product ID:           	100000000000000
Version:              	3.11
Arch:                 	s390x
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for i386 Bits
Product ID:           	100000000000001
Version:              	3.11
Arch:                 	i386
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86 Bits
Product ID:           	100000000000020
Version:              	8.6
Arch:                 	x86
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Shared File System Bits
Product ID:           	88888
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Multiplier Product Bits
Product ID:           	917571
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Load Balancing Bits
Product ID:           	37070
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

[root@bkearney ~]# subscription-manager facts --list | grep valid
system.entitlements_valid: invalid
[root@bkearney ~]#
Comment 2 Shwetha Kallesh 2012-08-17 01:58:31 EDT
I just registered my client..thats it..

[root@dhcp201-115 consumer]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5

With latest version I cannot reproduce the same ..

[root@dhcp201-115 ~]# subscription-manager register --force --org=admin
Username: admin
Password: 
The system has been registered with id: 9e9842db-d51e-4621-93a7-3092a66fa486 
[root@dhcp201-115 ~]# subscription-manager facts --list | grep system.entitlements_valid
system.entitlements_valid: invalid

[root@dhcp201-115 consumer]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Awesome OS for S390 Bits
Product ID:           	100000000000060
Version:              	3.11
Arch:                 	s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for ia64 Bits
Product ID:           	100000000000006
Version:              	3.11
Arch:                 	ia64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for i686 Bits
Product ID:           	100000000000005
Version:              	3.11
Arch:                 	i686
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS for x86_64 Bits
Product ID:           	100000000000002
Version:              	3.11
Arch:                 	x86_64
Status:               	Not Subscribed
Starts:               	
Ends:
Comment 3 Bryan Kearney 2012-08-17 09:13:05 EDT
ok.. I am gonna close this. If you see it again, we can re-open. Thanks!

Note You need to log in before you can comment on or make changes to this bug.