Bug 836524 - OPTIONS only allows one value in autofs.service
OPTIONS only allows one value in autofs.service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
: 839108 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 07:55 EDT by Michael Young
Modified: 2012-07-25 23:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 23:54:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2012-06-29 07:55:38 EDT
In /etc/sysconfig/autofs you used to be able to supply space separated options in the OPTIONS value, eg.
OPTIONS="-d -Osec=krb5"
With the current autofs.service script this no longer works, because systemd is treating it as a single argument so only a single option will work.

Multiple options can be made to work again by replacing the line
ExecStart=/usr/sbin/automount ${OPTIONS} --pid-file /run/autofs.pid
with
ExecStart=/usr/sbin/automount $OPTIONS --pid-file /run/autofs.pid
in /lib/systemd/system/autofs.service .
Comment 1 Ian Kent 2012-07-11 21:22:06 EDT
*** Bug 839108 has been marked as a duplicate of this bug. ***
Comment 2 Michael Young 2012-07-12 04:43:14 EDT
Re: Comment 4 of Bug 839108

It isn't a systemd bug, it is a systemd feature; see the ExecStart= section of the systemd.service manual page.
Comment 3 Ian Kent 2012-07-12 06:59:38 EDT
(In reply to comment #2)
> Re: Comment 4 of Bug 839108
> 
> It isn't a systemd bug, it is a systemd feature; see the ExecStart= section
> of the systemd.service manual page.

Yeah, I guess.
I'll make the change.
Comment 4 Fedora Update System 2012-07-15 22:57:00 EDT
autofs-5.0.6-21.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/autofs-5.0.6-21.fc17
Comment 5 Charlie Wyse 2012-07-16 14:10:13 EDT
The package worked for us.  Thanks.
Comment 6 Fedora Update System 2012-07-17 13:25:30 EDT
Package autofs-5.0.6-21.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing autofs-5.0.6-21.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10718/autofs-5.0.6-21.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-07-25 23:54:50 EDT
autofs-5.0.6-21.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.