This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 836652 - f17 trousers fails to start
f17 trousers fails to start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: trousers (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Steve Grubb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 15:59 EDT by Reartes Guillermo
Modified: 2012-08-29 10:42 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 10:42:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reartes Guillermo 2012-06-29 15:59:19 EDT
Description of problem:
I noticed another 'new' systemd unit failing. 

# dmesg| grep -i failed
[    9.171094] systemd[1]: Unit tcsd.service entered failed state.

# systemctl status tcsd.service
tcsd.service - LSB: Init script for TCSD
          Loaded: loaded (/etc/rc.d/init.d/tcsd)
          Active: failed (Result: exit-code) since Fri, 29 Jun 2012 15:47:10 -0300; 6min ago
         Process: 935 ExecStart=/etc/rc.d/init.d/tcsd start (code=exited, status=137)
          CGroup: name=systemd:/system/tcsd.service

What is it?  After some quick searches...
After a yum whatprovides.... i got:

trousers-0.3.6-2.fc17.x86_64 : TCG's Software Stack v1.2
Repo        : @fedora
Matched from:
Filename    : /etc/rc.d/init.d/tcsd
Filename    : /usr/share/man/man5/tcsd.conf.5.gz
Filename    : /usr/sbin/tcsd
Filename    : /usr/share/man/man8/tcsd.8.gz
Filename    : /etc/tcsd.conf

I am not familiar with this component.
'trousers' should have been in the description of the unit, IMHO.

# yum list trousers
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.symnds.com
 * rpmfusion-free: mirror.us.leaseweb.net
 * rpmfusion-free-updates: mirror.us.leaseweb.net
 * rpmfusion-nonfree: mirror.us.leaseweb.net
 * rpmfusion-nonfree-updates: mirror.us.leaseweb.net
 * updates: mirror.symnds.com
Installed Packages
trousers.x86_64        0.3.6-2.fc17         @fedora
Available Packages
trousers.i686

# grep trousers /var/log/yum.log
Jun 28 07:45:45 Installed: trousers-0.3.6-2.fc17.x86_64

I was installed with the last batch of updates, it seems. So it was not 
installed by my own volition, so it is failing by its own.

# dmesg | grep tcsd.service
[    9.157068] systemd[1]: tcsd.service: control process exited, code=exited status=137
[    9.171094] systemd[1]: Unit tcsd.service entered failed state.

# grep -i tcsd.service /var/log/messages*

Wow, nothing in messages.

# systemctl -a| grep trousers
# systemctl -a| grep tcsd
tcsd.service              loaded failed   failed        LSB: Init script for TCSD

# ls -l /lib/modules/$(uname -r)/kernel/drivers/char/tpm/
total 48
-rwxr--r--. 1 root root 12448 Jun 18 17:03 tpm_bios.ko
-rwxr--r--. 1 root root 31816 Jun 18 17:03 tpm.ko

# lsmod | grep -i tpm
tpm_bios               13528  0 

# /etc/rc.d/init.d/tcsd start
Starting tcsd (via systemctl):  Job failed. See system journal and 'systemctl status' for details.
                                                           [FAILED]

# grep tss /etc/passwd
tss:x:59:59:Account used by the trousers package to sandbox the tcsd daemon:/dev/null:/sbin/nologin

# grep tss /etc/group
tss:x:59:


Should i disable it?
Shouldn't it be disabled by default instead?
Is it is realy failing/failed?


I performed a reboot:

# grep tcsd.service /var/log/messages*
/var/log/messages:Jun 29 16:29:03 ulquiorra systemd[1]: tcsd.service: control process exited, code=exited status=137
/var/log/messages:Jun 29 16:29:03 ulquiorra systemd[1]: Unit tcsd.service entered failed state.
/var/log/messages:Jun 29 16:34:30 ulquiorra systemd[1]: tcsd.service: control process exited, code=exited status=137
/var/log/messages:Jun 29 16:34:30 ulquiorra systemd[1]: Unit tcsd.service entered failed state.

# dmesg | grep tcsd.service
[    9.110306] systemd[1]: tcsd.service: control process exited, code=exited status=137
[    9.128894] systemd[1]: Unit tcsd.service entered failed state.

# systemctl status tcsd.service
tcsd.service - LSB: Init script for TCSD
          Loaded: loaded (/etc/rc.d/init.d/tcsd)
          Active: failed (Result: exit-code) since Fri, 29 Jun 2012 16:46:09 -0300; 3min 0s ago
         Process: 964 ExecStart=/etc/rc.d/init.d/tcsd start (code=exited, status=137)
          CGroup: name=systemd:/system/tcsd.service

# systemctl stop tcsd.service

# systemctl start tcsd.service
Job failed. See system journal and 'systemctl status' for details.

# systemctl status tcsd.service
tcsd.service - LSB: Init script for TCSD
          Loaded: loaded (/etc/rc.d/init.d/tcsd)
          Active: failed (Result: exit-code) since Fri, 29 Jun 2012 16:53:43 -0300; 6s ago
         Process: 2237 ExecStart=/etc/rc.d/init.d/tcsd start (code=exited, status=137)
          CGroup: name=systemd:/system/tcsd.service

Jun 29 16:53:43 ulquiorra.espada tcsd[2237]: tpm_bios               13528  0
  
Kernel: 3.4.3-1.fc17.x86_64
Comment 1 Richard Shaw 2012-08-08 18:42:30 EDT
I'm seeing this as well on a Acer Aspire 5535

$ uname -r
3.3.8-1.fc16.x86_64


$ rpm -qa | grep trousers
trousers-0.3.6-1.fc16.x86_64
Comment 2 Steve Grubb 2012-08-29 10:42:19 EDT
The 3.3 kernel disabled tpm. Its enabled again.

Note You need to log in before you can comment on or make changes to this bug.