Bug 836661 - convert "<" and ">" inside <pre> element to html entities automagically
convert "<" and ">" inside <pre> element to html entities automagically
Status: CLOSED NOTABUG
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.9.2
Assigned To: June Zhang
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 16:50 EDT by David Jaša
Modified: 2015-03-05 04:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 04:07:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jaša 2012-06-29 16:50:44 EDT
Description of problem:
convert "<" and ">" inside <pre> element to html entities 

Version-Release number of selected component (if applicable):
3.7.0

How reproducible:


Steps to Reproduce:
1. enter this in HTML input of setup/action/breakdown/results fields:
<pre>
<xml>
  <element>example</element>
</xml>
</pre>
2. save the case
3.
  
Actual results:
only "example" and newlines are displayed

Expected results:
everything is displayed as in steps to reproduce

Additional info:
Comment 1 cqi 2014-12-20 22:12:47 EST
cannot reproduce in prod. should be fixed in previous releases. can u verify again? if it works as expected, this bug can be closed.
Comment 3 cqi 2015-03-05 04:07:10 EST
Version running in production has moved to 3.8.17. This bug does not happen now. Close. Feel free to reopen if you encounter this again.

Note You need to log in before you can comment on or make changes to this bug.