Bug 836744 - SELinux is preventing /usr/bin/totem-video-thumbnailer from read, append access on the chr_file /dev/tty2.
SELinux is preventing /usr/bin/totem-video-thumbnailer from read, append acce...
Status: CLOSED DUPLICATE of bug 836743
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f9bb48cae4566f9c66e736de45b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-30 15:34 EDT by Stef Walter
Modified: 2012-07-01 17:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-01 17:41:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-06-30 15:34:01 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.4-5.fc17.x86_64
time:           Sat 30 Jun 2012 09:33:50 PM CEST

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from read, append access on the chr_file /dev/tty2.
:
:*****  Plugin restorecon (93.9 confidence) suggests  *************************
:
:If you want to fix the label. 
:/dev/tty2 default label should be tty_device_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /dev/tty2
:
:*****  Plugin leaks (6.10 confidence) suggests  ******************************
:
:If you want to ignore totem-video-thumbnailer trying to read append access the tty2 chr_file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/bin/totem-video-thumbnailer /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (1.43 confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed read append access on the tty2 chr_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:user_tty_device_t:s0
:Target Objects                /dev/tty2 [ chr_file ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           evince-3.5.2-1.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-132.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed)
:                              3.3.4-5.fc17.x86_64 #1 SMP Mon May 7 17:29:34 UTC
:                              2012 x86_64 x86_64
:Alert Count                   3
:First Seen                    Sat 30 Jun 2012 03:14:34 PM CEST
:Last Seen                     Sat 30 Jun 2012 03:14:41 PM CEST
:Local ID                      9ae00d60-f1a8-410b-ad79-2fa72f892974
:
:Raw Audit Messages
:type=AVC msg=audit(1341062081.608:2860): avc:  denied  { read append } for  pid=21395 comm="evince-thumbnai" path="/dev/tty2" dev="devtmpfs" ino=1044 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tty_device_t:s0 tclass=chr_file
:
:
:type=AVC msg=audit(1341062081.608:2860): avc:  denied  { read append } for  pid=21395 comm="evince-thumbnai" path="/dev/tty2" dev="devtmpfs" ino=1044 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tty_device_t:s0 tclass=chr_file
:
:
:type=SYSCALL msg=audit(1341062081.608:2860): arch=x86_64 syscall=execve success=yes exit=0 a0=7fe3a8002eff a1=7fe3a8019e00 a2=7fff91a7c708 a3=a items=0 ppid=19821 pid=21395 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=4 comm=evince-thumbnai exe=/usr/bin/evince-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,user_tty_device_t,chr_file,read,append
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-07-01 17:41:59 EDT

*** This bug has been marked as a duplicate of bug 836743 ***

Note You need to log in before you can comment on or make changes to this bug.