Bug 836837 - Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0) on power cable removal
Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0) on power ...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 17:38 EDT by Eugene Kovalenja
Modified: 2012-07-25 03:05 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-25 03:05:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kovalenja 2012-07-01 17:38:13 EDT
Hi, all

Description of problem:

When I removed the power cable from my laptop, nothing happens (the icon of power management in the kde tray still inform that cable connected).

And in /var/log/message added several new lines:

Jul  2 00:22:03 ekovalenja-lt kernel: [  167.347736] atkbd serio0: Unknown key pressed (translated set 2, code 0xf1 on isa0060/serio0).
Jul  2 00:22:03 ekovalenja-lt kernel: [  167.347742] atkbd serio0: Use 'setkeycodes e071 <keycode>' to make it known.
Jul  2 00:22:03 ekovalenja-lt kernel: [  167.358388] atkbd serio0: Unknown key released (translated set 2, code 0xf1 on isa0060/serio0).
Jul  2 00:22:03 ekovalenja-lt kernel: [  167.358396] atkbd serio0: Use 'setkeycodes e071 <keycode>' to make it known.


Version-Release number of selected component (if applicable):

Linux ekovalenja-lt 3.4.4-3.fc17.x86_64 #1 SMP Tue Jun 26 20:54:56 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

This problem came after fedora upgraded from 16 to 17

How reproducible:

Remove power cable from laptop
  
Actual results:

Nothing happens

Expected results:

OS should inform about "cable removed" in the kde tray

Additional info:

Laptop: Lenovo Thinkpad 0301-RJ8

All release packages are up to date
Comment 1 Josh Boyer 2012-07-06 10:26:57 EDT
Can you run 'udevadm monitor' as root while the machine is plugged in, unplug it, wait a few seconds, plug it back in, and then attach the output you see here?

Basically, your machine sends power events through the keyboard controller which is apparently common.  The above test will show us if the power state is actually toggling.
Comment 2 Eugene Kovalenja 2012-07-06 11:54:34 EDT
Hi, Josh

Thank you for your response

See output below:

[ekovalenja@ekovalenja-lt ~]$ sudo udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent
Comment 3 Eugene Kovalenja 2012-07-25 03:05:34 EDT
Hi 

Can't reproduce this problem after I upgraded to kernel-3.4.6-2.fc17.x86_64

Note You need to log in before you can comment on or make changes to this bug.