Bug 836847 - Exiting anaconda abnormally on an installed running system results in reboot
Exiting anaconda abnormally on an installed running system results in reboot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-01 19:00 EDT by Peter H. Jones
Modified: 2013-01-10 01:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-02 16:28:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2012-07-01 19:00:23 EDT
Description of problem:
Aborting anaconda on a running system causes unexpected reboot.

Version-Release number of selected component (if applicable):
anaconda-17.29-1.fc17.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install anaconda, if not already present.
2. Become root in command line.
3. Enter anaconda, with no options.
4. When first window (language selection), click on upper right corner to close it, since no abort choice is offered.
5. A dialog appears offering to Exit Installer.
6. Click on Exit Installer.
  
Actual results:
Machine reboots immediately.

Expected results:
Simple return to command line.

Additional info:

This is an unusual use of anaconda, as it is not in a boot environment. I was thinking of using anaconda on a running x86_64 system to prepare a Fedora system for a low-memory i686 target system, using i686 repos.

I wish it were possible to run anaaconda as a normal user, using image files instead of real partitions, as qemu does. This approach would be far less risky for the running system.

I'll try booting the i386 DVD on my running system and installing an i386 system to a USB drive. I'll avoid letting the installation touch the hard disk of the running system. Once I have the USB installation, I can copy its files to the target. The target lacks a USB boot, so I'll have to install a bootloader on the target.
Comment 1 Jesse Keating 2012-07-02 16:28:00 EDT
Anaconda is not designed to run in that way.  If you want to install to an image file, there is a new --image option which you can use to point to a disk image to do the install.  When in --image mode I don't believe a reboot will happen in the case of a crash.

There is also livemedia-creator which can be used to setup disk images for other systems.

Note You need to log in before you can comment on or make changes to this bug.