Bug 836883 - The error message about cpuset was not completely
The error message about cpuset was not completely
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-virtinst (Show other bugs)
6.3
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 01:54 EDT by Cui Lei
Modified: 2013-04-16 01:16 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-08 17:14:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cui Lei 2012-07-02 01:54:12 EDT
Description of problem:
Execute a python-virtinst command with cpuset option like below one, such as
virt-image -n $guestname $xmlfile --cpuset=1,^4,a

The error message would pop up:
"ERROR    cpuset can only contain numeric, ',', or '-' characters"

But the error message was not completely, which should include '^' characters, which means not use.


Version-Release number of selected component (if applicable):

python-virtinst-0.600.0-8.el6.noarch
qemu-kvm-0.12.1.2-2.295.el6.x86_64
libvirt-0.9.10-21.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. execute a command as "virt-image -n $guestname $xmlfile --cpuset=1,^4,a"
2. check the error message

Actual results:
Error output, which hint
"ERROR    cpuset can only contain numeric, ',', or '-' characters"
which should include '^' characters, which means not use.

Expected results:
The error message should completely.
Comment 1 Cole Robinson 2012-07-08 17:14:53 EDT
Thanks, fixed upstream:

http://git.fedorahosted.org/git?p=python-virtinst.git;a=commit;h=7a7f33dcef1432231b79058e346d5a279ed4716f

But since this is so minor I'm just closing as UPSTREAM

Note You need to log in before you can comment on or make changes to this bug.