Bug 836887 - engine-manage-domains does not support proper usage of log4j.xml for logging configuration
engine-manage-domains does not support proper usage of log4j.xml for logging ...
Status: CLOSED DUPLICATE of bug 825994
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 02:27 EDT by Yair Zaslavsky
Modified: 2016-02-10 14:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-01 07:55:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yair Zaslavsky 2012-07-02 02:27:42 EDT
Description of problem:

In contrast to engine-config which uses log4j.xml file from a well-defined location on the file system - (/etc/rhevm/engine-config/log4j.xml) , engine-manage-domains has no such functionality and requires log4j.xml to reside in the classpath, which currently does not take place.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

engine-manage-domains should use a log4j.xml file defined at 
/etc/rhevm/engine-manage-domains/log4j.xml


Additional info:
Comment 2 Yair Zaslavsky 2012-07-08 02:45:27 EDT
QE should test the following -
a. /etc/rhevm/engine-manage-domains/log4j.xml is located at the file system, and when running engine-manage-domains the log file is created at /var/log/engine/engine-manage-domains/engine-manage-domains.log
b. Change log4j.xml configuration and see how it effects the log.
For example - change  priority value to "DEBUG" at  the category of 
org.ovirt.engine.core.utils.kerberos
Comment 3 Yair Zaslavsky 2012-08-01 07:55:05 EDT

*** This bug has been marked as a duplicate of bug 825994 ***

Note You need to log in before you can comment on or make changes to this bug.