Bug 836894 - "subscription-manager repos --enable= " displays list known repos for the system
"subscription-manager repos --enable= " displays list known repos for the system
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-02 02:38 EDT by Shwetha Kallesh
Modified: 2013-01-10 04:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation required.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-07-02 02:38:22 EDT
Description of problem:
"subscription-manager repos --enable= " displays list known repos for the system

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.[root@dhcp201-196 ~]# subscription-manager repos --enable=


Actual results:
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
Repo Id:              	awesomeos
Repo Name:            	awesomeos
Repo Url:             	https://cdn.redhat.com/path/to/$basearch/$releasever/awesomeos
Enabled:              	1

Repo Id:              	awesomeos-x86_64
Repo Name:            	awesomeos-x86_64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/x86_64
Enabled:              	0

Repo Id:              	awesomeos-modifier
Repo Name:            	awesomeos-modifier
Repo Url:             	http://example.com/awesomeos-modifier
Enabled:              	1

Repo Id:              	awesomeos-ppc
Repo Name:            	awesomeos-ppc
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ppc
Enabled:              	0

Repo Id:              	always-enabled-content
Repo Name:            	always-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/always/$releasever
Enabled:              	1

Repo Id:              	never-enabled-content
Repo Name:            	never-enabled-content
Repo Url:             	https://cdn.redhat.com/foo/path/never
Enabled:              	0

Repo Id:              	content-label-empty-gpg
Repo Name:            	content-emptygpg
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

Repo Id:              	awesomeos-s390x
Repo Name:            	awesomeos-s390x
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/s390x
Enabled:              	0

Repo Id:              	content-label-no-gpg
Repo Name:            	content-nogpg
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1

Repo Id:              	awesomeos-ia64
Repo Name:            	awesomeos-ia64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ia64
Enabled:              	0

Repo Id:              	awesomeos-ppc64
Repo Name:            	awesomeos-ppc64
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/ppc64
Enabled:              	0

Repo Id:              	awesomeos-i686
Repo Name:            	awesomeos-i686
Repo Url:             	https://cdn.redhat.com/path/to/awesomeos/i686
Enabled:              	0

Repo Id:              	content-label
Repo Name:            	content
Repo Url:             	https://cdn.redhat.com/foo/path
Enabled:              	1


Expected results:

Error: A valid repo id is required. Use --list option to see valid repos.

Additional info:
Comment 1 Shwetha Kallesh 2012-07-02 05:01:53 EDT
RPM version:
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-firstboot-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-migration-data-1.11.2.1-1.git.8.87961f3.el5
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5
Comment 2 Bryan Kearney 2012-08-16 12:36:49 EDT
I am not seeing this in 1.0.13 test version. Please re-verity with 1.0.14 or later.
Comment 3 RHEL Product and Program Management 2012-08-16 12:37:02 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Shwetha Kallesh 2012-08-17 07:44:32 EDT
Marking verified!!

[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5



[root@dhcp201-115 ~]# subscription-manager repos --enable= 
Error: A valid repo id is required. Use --list option to see valid repos.
Comment 6 errata-xmlrpc 2013-01-07 22:56:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.