Bug 836933 - subscription-manager service-level --set=" " sets the service-level to null
subscription-manager service-level --set=" " sets the service-level to null
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-02 04:54 EDT by Shwetha Kallesh
Modified: 2013-01-07 22:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-07-02 04:54:32 EDT
Description of problem:
subscription-manager service-level --set=" " sets the service-level to null

Version-Release number of selected component (if applicable):
[root@dhcp201-196 ~]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-firstboot-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-migration-data-1.11.2.1-1.git.8.87961f3.el5
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5


How reproducible:


Steps to Reproduce:
1.[root@dhcp201-196 ~]# subscription-manager service-level --set=" "
Service level set to:  
[root@dhcp201-196 ~]# subscription-manager service-level 
Current service level:  

  
Actual results:


Expected results:
Service level preference not set

Additional info:
Comment 1 Bryan Kearney 2012-08-14 14:58:41 EDT
fixed in master at 2a76fe74b8ba4a082b1541a1fae491469503e0b8
Comment 2 RHEL Product and Program Management 2012-08-14 15:17:27 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Shwetha Kallesh 2012-08-17 07:44:36 EDT
Marking verified!!

[root@dhcp201-115 ~]# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-gui-1.0.13-1.git.45.5cb55c8.el5
subscription-manager-migration-1.0.13-1.git.45.5cb55c8.el5



[root@dhcp201-115 ~]# subscription-manager service-level --set=""
Service level preference has been unset
[root@dhcp201-115 ~]# subscription-manager service-level 
Service level preference not set
Comment 5 errata-xmlrpc 2013-01-07 22:56:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.