Bug 836967 - "<type 'exceptions.NameError'>: global name '_' is not defined" in rhn_check
"<type 'exceptions.NameError'>: global name '_' is not defined" in rhn_check
Status: CLOSED DUPLICATE of bug 830776
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 06:55 EDT by Jan Hutař
Modified: 2012-08-06 05:21 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 05:21:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2012-07-02 06:55:27 EDT
Description of problem:
When there are 2 rhn_check-s running, instead of error message "Attempting to run more than one instance of rhn_check. Exiting." we get traceback "<type 'exceptions.NameError'>: global name '_' is not defined"


Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-87.el6.noarch.rpm


How reproducible:
always


Steps to Reproduce:
1. rhn_check & ; rhn_check


Actual results:
On command line:
An error has occurred:
<type 'exceptions.NameError'>
See /var/log/up2date for more information

In /var/log/up2date:
[Mon Jul  2 06:50:34 2012] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 383, in <module>
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 96, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_check", line 74, in main
    CheckCli.__check_instance_lock()
  File "/usr/sbin/rhn_check", line 378, in __check_instance_lock
    sys.stderr.write(rhncli.utf8_encode(_("Attempting to run more than one instance of rhn_check. Exiting.\n")))
<type 'exceptions.NameError'>: global name '_' is not defined


Expected results:
Just error message "Attempting to run more than one instance of rhn_check. Exiting." should be printed.


Additional info:
This seems to be a regression caused by spacewalk.git commit 276bca83.
Comment 2 RHEL Product and Program Management 2012-07-10 04:16:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2012-07-10 21:51:02 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 4 Milan Zazrivec 2012-08-06 05:21:43 EDT

*** This bug has been marked as a duplicate of bug 830776 ***

Note You need to log in before you can comment on or make changes to this bug.