Bug 836981 - [abrt] audacious-3.2.3-1.fc17: gtk_grab_notify_foreach: Process /usr/bin/audacious was killed by signal 11 (SIGSEGV)
[abrt] audacious-3.2.3-1.fc17: gtk_grab_notify_foreach: Process /usr/bin/auda...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Schwendt
Fedora Extras Quality Assurance
abrt_hash:70f2e741a28efafad7ba834ec24...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 07:58 EDT by Cristian Ciupitu
Modified: 2013-06-06 05:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-06 05:48:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (146.58 KB, text/plain)
2012-07-02 07:58 EDT, Cristian Ciupitu
no flags Details
File: backtrace (770.44 KB, text/plain)
2012-07-02 07:58 EDT, Cristian Ciupitu
no flags Details
File: maps (42.65 KB, text/plain)
2012-07-02 07:58 EDT, Cristian Ciupitu
no flags Details
File: dso_list (9.07 KB, text/plain)
2012-07-02 07:58 EDT, Cristian Ciupitu
no flags Details

  None (edit)
Description Cristian Ciupitu 2012-07-02 07:58:19 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        audacious
comment:        I was playing with the volume control and the playlist (moving songs).
crash_function: gtk_grab_notify_foreach
executable:     /usr/bin/audacious
kernel:         3.4.4-3.fc17.x86_64
pid:            14882
pwd:            /home/ciupicri
time:           Mon 02 Jul 2012 02:33:25 PM EEST
uid:            1000
username:       ciupicri

backtrace:      Text file, 788926 bytes
core_backtrace: Text file, 150101 bytes
dso_list:       Text file, 9290 bytes
maps:           Text file, 43672 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/ciupicri/1

environ:
:GIT_PS1_SHOWDIRTYSTATE=true
:XDG_VTNR=1
:XDG_SESSION_ID=1
:SSH_AGENT_PID=1592
:HOSTNAME=hermes.lizeanunet.tld
:GLADE_PIXMAP_PATH=:
:XDG_MENU_PREFIX=xfce-
:SHELL=/bin/bash
:HISTSIZE=21000
:QT_GRAPHICSSYSTEM_CHECKED=1
:HISTFILESIZE=21000
:USER=ciupicri
:GLADE_MODULE_PATH=:
:SSH_AUTH_SOCK=/run/user/ciupicri/keyring-obLZrn/ssh
:USERNAME=ciupicri
:XDG_CONFIG_DIRS=/etc/xdg
:MAIL=/var/spool/mail/ciupicri
:DESKTOP_SESSION=xfce
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/ciupicri/.local/bin:/home/ciupicri/bin
:PWD=/home/ciupicri
:EDITOR=vim
:KDE_IS_PRELINKED=1
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:GIT_PS1_SHOWUNTRACKEDFILES=true
:GDMSESSION=xfce
:HISTCONTROL=ignoredups
:SHLVL=2
:HOME=/home/ciupicri
:XDG_SEAT=seat0
:LOGNAME=ciupicri
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-93CzhznENo,guid=181a92439110a61e16ae3c9300000022
:XDG_DATA_DIRS=/usr/local/share:/usr/share
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/ciupicri
:GLADE_CATALOG_PATH=:
:TSOCKS_CONF_FILE=/home/ciupicri/.tsocks.conf
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-ciupicri-WJvJ0p/database
:_=/usr/bin/xfce4-session
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1614,unix/unix:/tmp/.ICE-unix/1614
:GNOME_KEYRING_CONTROL=/run/user/ciupicri/keyring-obLZrn
:GPG_AGENT_INFO=/run/user/ciupicri/keyring-obLZrn/gpg:0:1
:GNOME_KEYRING_PID=1619
:DISPLAY=:0.0

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30942                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30942                30942                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/ciupicri/.xsession-errors
:pos:	6068526
:flags:	0102002
:2:/home/ciupicri/.xsession-errors
:pos:	6068526
:flags:	0102002
:3:socket:[66563]
:pos:	0
:flags:	02000002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[66564]
:pos:	0
:flags:	02004002
:6:socket:[66569]
:pos:	0
:flags:	02004002
:7:socket:[66573]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:socket:[66575]
:pos:	0
:flags:	02004002
:11:pipe:[161224]
:pos:	0
:flags:	02004000

var_log_messages:
:Jun 26 03:39:16 hermes yum[20876]: Installed: audacious-libs-3.2.3-1.fc17.x86_64
:Jun 26 03:39:30 hermes yum[20876]: Installed: audacious-plugins-3.2.3-1.fc17.x86_64
:Jun 26 03:39:55 hermes yum[20876]: Installed: audacious-3.2.3-1.fc17.x86_64
:Jun 26 03:45:35 hermes yum[21124]: Installed: audacious-plugins-freeworld-mms-3.2-3.fc17.x86_64
:Jun 26 03:45:35 hermes yum[21124]: Installed: audacious-plugins-freeworld-mp3-3.2-3.fc17.x86_64
:Jun 26 06:41:56 hermes yum[1741]: Installed: audacious-plugins-freeworld-ffaudio-3.2-3.fc17.x86_64
:Jun 26 06:41:57 hermes yum[1741]: Installed: audacious-plugins-freeworld-aac-3.2-3.fc17.x86_64
:Jul  2 14:33:25 hermes kernel: [35090.256456] audacious[14882]: segfault at 7fffd609dfe8 ip 00000035ef379290 sp 00007fffd609e018 error 6 in libgtk-3.so.0.400.3[35ef200000+472000]
:Jul  2 14:33:26 hermes abrt[30253]: Saved core dump of pid 14882 (/usr/bin/audacious) to /var/spool/abrt/ccpp-2012-07-02-14:33:25-14882 (98951168 bytes)

xsession_errors:
:(audacious:14882): Gtk-WARNING **: Theme parsing error: gtk.css:84:30: Failed to import: Error opening file: No such file or directory
:(audacious:14882): Gtk-WARNING **: Theme parsing error: gtk.css:85:38: Failed to import: Error opening file: No such file or directory
Comment 1 Cristian Ciupitu 2012-07-02 07:58:23 EDT
Created attachment 595704 [details]
File: core_backtrace
Comment 2 Cristian Ciupitu 2012-07-02 07:58:30 EDT
Created attachment 595705 [details]
File: backtrace
Comment 3 Cristian Ciupitu 2012-07-02 07:58:32 EDT
Created attachment 595706 [details]
File: maps
Comment 4 Cristian Ciupitu 2012-07-02 07:58:34 EDT
Created attachment 595707 [details]
File: dso_list
Comment 5 Michael Schwendt 2012-07-02 09:54:20 EDT
https://bugzilla.redhat.com/buglist.cgi?quicksearch=gtk_grab_notify_foreach

Similar to bug 830534 (totem).

| #2035 0x00000035ef3de9d1 in gtk_scale_button_grab_notify (button=<optimized
| out>, was_grabbed=<error reading variable: Unhandled dwarf expression opcode
| 0xfa>) at gtkscalebutton.c:1178
Comment 6 Michael Schwendt 2013-06-06 05:48:46 EDT
Assuming this has been fixed in GTK+ since Fedora 18. If you can reproduce it with a newer release of Fedora including a newer release of Audacious, feel free to open a new report.

Note You need to log in before you can comment on or make changes to this bug.