Bug 836995 - vdsm-bootstrap: install only really required RPMs
vdsm-bootstrap: install only really required RPMs
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.2
Assigned To: Dan Kenigsberg
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 09:10 EDT by Yaniv Kaul
Modified: 2013-07-03 22:47 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 06:53:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2012-07-02 09:10:26 EDT
Description of problem:
The current list of required RPMs is:
VDS_PACK = ('qemu-kvm', 'qemu-kvm-tools', VDSM_NAME, VDSM_NAME+'-cli',
'libjpeg', 'spice-server', 'pixman',
                'seabios', 'qemu-img', 'fence-agents',
                 'libselinux-python')

But actually, if we have VDSM, VDSM-cli, qemu-kvm:
qemu-img is a dependency of qemu-kvm 
seabios is a dependency of qemu-kvm
spice-server is a dependency of qemu-kvm
libjpeg is a dependency of spice-server
pixman is a dependency of spice-server

As for REQ_PACK = ('SDL.x86_64','bridge-utils.x86_64','mesa-libGLU.x86_64',
             'openssl.x86_64','m2crypto.x86_64','rsync.x86_64')

SDL - we don't need it (belonged to spice-server?
mesa-libGLU - we don't need it (belonged to spice-server?
m2crypto - we don't need it (fixed in http://gerrit.ovirt.org/#/c/5789/1/vds_bootstrap/vds_bootstrap.py)
rsync - not sure why we need it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Kaul 2012-07-02 09:20:52 EDT
Note from Dan reminded me that the reason we ask for direct (and indirect dependencies) is to provide the user with more informative error in case of missing packages. Therefore I've changed the request to actually remove obsolete dependencies - SDL and mesa-libGLU
I do think we should remove libjpeg (as spice in upstream asks for libjpeg-turbo)
Comment 2 Itamar Heim 2012-07-02 10:12:06 EDT
(In reply to comment #1)
> Note from Dan reminded me that the reason we ask for direct (and indirect
> dependencies) is to provide the user with more informative error in case of
> missing packages. Therefore I've changed the request to actually remove
> obsolete dependencies - SDL and mesa-libGLU

agree, though hopefully we would be able to improve this in the future to get better error message even when asking to install all.
till then, these should be removed.

> I do think we should remove libjpeg (as spice in upstream asks for
> libjpeg-turbo)

libjpeg-turbo provides libjpeg, so i don't think this is an issue
Comment 3 Alon Bar-Lev 2013-03-12 06:53:42 EDT
Solved using yum api.

Note You need to log in before you can comment on or make changes to this bug.