Bug 837013 - Incorrect error message when trying to run VM on host which is down (unavailable) and VM is pinned to this host.
Incorrect error message when trying to run VM on host which is down (unavaila...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Shahar Havivi
Pavel Stehlik
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 10:13 EDT by Leonid Natapov
Modified: 2012-12-04 15:12 EST (History)
12 users (show)

See Also:
Fixed In Version: si12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture (118.65 KB, image/png)
2012-07-02 10:13 EDT, Leonid Natapov
no flags Details

  None (edit)
Description Leonid Natapov 2012-07-02 10:13:03 EDT
Created attachment 595741 [details]
picture

Incorrect error message when trying to run VM on host which is down (unavailable) and VM is pinned to this host.

Look at attached picture.

Actually two bugs.
------------------
The first one the "${action}".

The second one is that message says to run VM once in order to manually select host. This is wrong. No such an option in Run Once.
Comment 1 Leonid Natapov 2012-07-02 10:15:34 EDT
This is CanDoAction:
2012-07-02 17:06:45,880 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (ajp--0.0.0.0-8009-9) CanDoAction of action RunVm failed. Reasons:VM_PINNED_TO_HOST_CANNOT_RUN_ON_THE_DEFAULT_VDS,VAR__TYPE__VM,ACTION_TYPE_FAILED_VDS_VM_CLUSTER
Comment 2 Barak 2012-07-08 12:14:40 EDT
It sounds to me like we need to be able add the ability to override the "pin to host" option in the runOnce dialog.

Andrew ?

It means that in case we are talking on a virt-appliance it may conflict with other configuration ... e.g. promiscuous mode VM ?
Comment 3 Shahar Havivi 2012-07-17 07:32:12 EDT
Cannot reproduce this, 
I am getting other error:
"Error while executing action: Cannot run VM: Storage Domain cannot be accessed. -Please check that at least one Host is operational and Data Center state is up."

tested on every host status.
Comment 4 Leonid Natapov 2012-07-18 04:43:18 EDT
OK. You MUST have more than 1 host in the same cluster and DC in order to be able to reproduce this bug. When there is only one host in DC the storage domain becomes unavailable when the host is not in the UP state. That's why the message "Storage Domain can not be accessed appears". So,in order to reproduce, have two hosts in DC,pin VM to one of the hosts and switch the host that VM pinned to it to maintenance. Try run VM.
Comment 5 Shahar Havivi 2012-07-18 07:27:26 EDT
posted at: http://gerrit.ovirt.org/#/c/6398/
Comment 6 Shahar Havivi 2012-07-18 10:54:25 EDT
merged at: 17b6522b4c0d4033cf8164c783cc87c8fbdccb67

Note You need to log in before you can comment on or make changes to this bug.