Bug 837036 - Error: --org is only supported with the --list command
Error: --org is only supported with the --list command
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity low
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-02 10:57 EDT by John Sefler
Modified: 2013-01-10 06:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-07-02 10:57:42 EDT
Description of problem:
This error message could be improved

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
[root@jsefler-59server ~]# subscription-manager service-level --username=username --password=password --org=admin

  
Actual results:
Error: --org is only supported with the --list command
                                               ^^^^^^^
The "--list" is a command line "option" for the service-level module.  It's not a command.

Expected results:
Error: --org is only supported with the --list option
                                               ^^^^^^


Additional info:
Comment 1 RHEL Product and Program Management 2012-07-02 11:07:23 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 James Bowes 2012-07-06 06:41:25 EDT
bk fixed this one up, in master 5699dca
Comment 4 Sharath Dwaral 2012-07-09 17:30:24 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.8-1.git.14.dfc8438.el5
python-rhsm-1.0.3-1.git.0.583d26c.el5
subscription-manager-firstboot-1.0.8-1.git.14.dfc8438.el5
subscription-manager-1.0.8-1.git.14.dfc8438.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.8-1.git.14.dfc8438.el5


Result:
# subscription-manager service-level --username testuser1 --password=password --org=admin
Error: --org is only supported with the --list option


Moiving Bug to VERIFIED
Comment 6 errata-xmlrpc 2013-01-07 22:56:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.