Bug 837106 - Need to change at-spi locator for register button
Need to change at-spi locator for register button
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-02 15:54 EDT by J.C. Molet
Modified: 2013-01-10 06:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
register button (46.21 KB, image/png)
2012-07-02 15:54 EDT, J.C. Molet
no flags Details
register system (208.42 KB, image/png)
2012-08-24 11:58 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2012-07-02 15:54:40 EDT
Created attachment 595801 [details]
register button

Description of problem:
Can we change the at-spi locator name for the register button next to the certificate status?  Its current name "Register" confuses it with the system menu register entry.  Because they share the same name, gnome and the at-spi libraries will randomly pick whatever object it happens to get first making the locator for this completely unreliable (and breaks automation).

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.7-1.git.10.4c364f3.el5

How to reproduce:
 - Look at subscription-manager-gui with sniff/dogtail
 - Try to call the register button with an at-spi library across restarts of subscription-manager-gui

Actual results:
The "Register" locator randomly points to the menu item or the actual button.

Expected results:
- The menu item would remain unchanged.
- The Register button next to the Certificate status could have the locator "Register System" (as it did before).
Comment 1 RHEL Product and Program Management 2012-07-02 16:07:18 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 James Bowes 2012-07-05 09:20:48 EDT
Pushed to master, 404dcd
Comment 5 J.C. Molet 2012-08-24 11:58:11 EDT
Created attachment 606906 [details]
register system

Testing with the latest in brew:
subscription-manager-gui-1.0.14-1.el5


The button has been renamed 'Register System' and all is well again with automation.

Marking VERIFIED.
Comment 7 errata-xmlrpc 2013-01-07 22:56:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.