Bug 837116 - Imported VM failed to connect to gofer broker
Imported VM failed to connect to gofer broker
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.1
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: 6.0
Assigned To: Jeff Ortel
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 16:31 EDT by Steve Reichard
Modified: 2014-09-18 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 11:24:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello debut (3.37 MB, text/plain)
2012-07-02 16:31 EDT, Steve Reichard
no flags Details

  None (edit)
Description Steve Reichard 2012-07-02 16:31:14 EDT
Created attachment 595803 [details]
katello debut

Description of problem:

Discovered in prep of CloudForms lab for summit.  

Reproduced in local environment

When a VM is made in RHEV, then imported into CF, the katello agent does not get the "connected to AMQP" message.

katello-debug from SE node attached.



Version-Release number of selected component (if applicable):


How reproducible:
eavery time so far

Steps to Reproduce:

Make Template
1. Create  a RHEV VM
2. Register it so it has access to CF tools
3. Install aeolus-audrey-agent, katello-agent, rhev-agent
4. subscription-manager clean
5. Remove HOSTNAME from /etc/sysconfig/network
6. Remove MACADDR from /etc/sysconfig/network-scripts/ifcfg-eth0
7. Remove /etc/udev/rules.d/70-persistent-net.rules
8. Create /etc/sysconfig/cloud-info - contents = CLOUD_TYPE="rhevm"
9. shutdown VM
10. create template.

11. Create a NEW VM from the template
12. Boot both the original VM and the new template-based VM
13. install bootstrap (yum localinstall http://cf-se1.../pub/...rpm
14.  subscription-manager register 



  
Actual results:

the templated VM /var/log/gofer/agent.log contained:

[messaging]
url=
uuid=6e03fec5-ec98-4e82-aed8-2d9cfeb0489b


2012-07-03 04:59:28,663 [INFO][pending] run() @ store.py:345 - started
2012-07-03 04:59:28,668 [INFO][MainThread] start() @ main.py:151 - agent started.
2012-07-03 05:02:12,816 [INFO][PathMonitor1] changed() @ katelloplugin.py:83 - changed: /etc/pki/consumer/cert.pem
2012-07-03 05:02:12,824 [INFO][katelloplugin-monitor] getbroker() @ plugin.py:192 - broker (qpid) configured: {cf-se1.cloud.lab.eng:
transport=SSL
host=cf-se1.cloud.lab.eng.bos.redhat.com
port=5674
cacert=/etc/rhsm/ca/candlepin-local.pem
clientcert=/etc/pki/consumer/bundle.pem
2012-07-03 05:02:12,825 [INFO][katelloplugin-monitor] update() @ main.py:123 - uuid="a473a76f-639a-4881-b987-bd59c543408a", attached
2012-07-03 05:02:12,826 [INFO][a473a76f-639a-4881-b987-bd59c543408a] connect() @ broker.py:100 - connecting:
{cf-se1.cloud.lab.eng.bos.redhat.com:5674}:
transport=SSL
host=cf-se1.cloud.lab.eng.bos.redhat.com
port=5674
cacert=/etc/rhsm/ca/candlepin-local.pem
clientcert=/etc/pki/consumer/bundle.pem
2012-07-03 05:02:12,915 [INFO][a473a76f-639a-4881-b987-bd59c543408a] connect() @ broker.py:103 - {cf-se1.cloud.lab.eng.bos.redhat.cP




Expected results:

the original system's log conatianed :

[messaging]
url=
uuid=admin@dhcp-144.cloud.lab.eng.bos.redhat.com


2012-07-03 01:00:35,159 [INFO][pending] run() @ store.py:345 - started
2012-07-03 01:00:35,161 [INFO][MainThread] start() @ main.py:151 - agent started.
2012-07-03 01:02:27,204 [INFO][PathMonitor1] changed() @ katelloplugin.py:83 - changed: /etc/pki/consumer/cert.pem
2012-07-03 01:02:28,204 [INFO][katelloplugin-monitor] getbroker() @ plugin.py:192 - broker (qpid) configured: {cf-se1.cloud.lab.eng.bos.redhat.com:5674}:
transport=SSL
host=cf-se1.cloud.lab.eng.bos.redhat.com
port=5674
cacert=/etc/rhsm/ca/candlepin-local.pem
clientcert=/etc/pki/consumer/bundle.pem
2012-07-03 01:02:28,205 [INFO][katelloplugin-monitor] update() @ main.py:123 - uuid="de4ca36f-19c9-446e-aa71-a7add77c059d", attached
2012-07-03 01:02:28,205 [INFO][de4ca36f-19c9-446e-aa71-a7add77c059d] connect() @ broker.py:100 - connecting:
{cf-se1.cloud.lab.eng.bos.redhat.com:5674}:
transport=SSL
host=cf-se1.cloud.lab.eng.bos.redhat.com
port=5674
cacert=/etc/rhsm/ca/candlepin-local.pem
clientcert=/etc/pki/consumer/bundle.pem
2012-07-03 01:02:28,311 [INFO][de4ca36f-19c9-446e-aa71-a7add77c059d] connect() @ broker.py:103 - {cf-se1.cloud.lab.eng.bos.redhat.com:5674} connected to AMQP


Additional info:
Comment 1 Jeff Ortel 2012-07-09 11:57:36 EDT
Connection to the broker is handled by python-qpid.  Can I get access to these VMs?  It would expedite my investigation.
Comment 2 Mike McCune 2013-08-16 14:16:37 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 3 Bryan Kearney 2014-09-04 11:24:45 EDT
This bug is no longer relevant since the features described are not part of Satellite 6. I am closing this out. If you feel it was closed in error, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.