Bug 837132 - Yum Plugin usability Improvements message
Yum Plugin usability Improvements message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748 832119
  Show dependency treegraph
 
Reported: 2012-07-02 17:53 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-07-02 17:53:12 EDT
Description of problem: Yum Plugin usability Improvements message has carriage returns which have to removed for the sake of consistency

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-firstboot-1.0.7-1.git.10.4c364f3.el5
subscription-manager-gui-1.0.7-1.git.10.4c364f3.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
python-rhsm-1.0.3-1.git.0.583d26c.el5
subscription-manager-migration-1.0.7-1.git.10.4c364f3.el5
subscription-manager-1.0.7-1.git.10.4c364f3.el5

How reproducible:
Always

Steps to Reproduce:

# subscription-manager register --username=stage_test_12
Password: 
The system has been registered with id: 03869a40-76b7-4a1a-94a1-b5fbe697670b 

# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Subscribed
Starts:               	04/27/2012
Ends:                 	04/26/2013

# date 050100002013
Wed May  1 00:00:00 EDT 2013

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is registered to Red Hat Subscription Management, but not recieving updates. You can use subscription-manager to assign subscriptions.

*** WARNING ***
The subscription for following product(s) has expired:
  - Red Hat Beta
  - Red Hat Enterprise Linux Server
You no longer have access to the repositories that
provide these products.  It is important that you apply an
active subscription in order to resume access to security
and other critical updates. If you don't have other active
subscriptions, you can renew the expired subscription.

This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0

Actual results:
As shown above

Expected results:
The warning mesage has carriage returns which have to be removed fo the sake of consistency.

Additional info:
Comment 1 RHEL Product and Program Management 2012-07-02 18:07:17 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Bryan Kearney 2012-07-23 15:39:26 EDT
Fixed in master at 8a552e3465f53b18e863da23df243acb04fa358f
Comment 4 Sharath Dwaral 2012-07-31 16:54:18 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-data-1.11.2.2-1.git.2.c3c8e22.el5
python-rhsm-1.0.4-1.git.6.19a55da.el5
subscription-manager-firstboot-1.0.11-1.git.3.b3c4a8b.el5
subscription-manager-migration-1.0.11-1.git.3.b3c4a8b.el5


Verification :

# subscription-manager register
Username: stage_test_12
Password: 
The system has been registered with id: 275f7133-a256-4f95-b5c8-edcbac174a46 

# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Subscribed
Starts:               	12/31/2011
Ends:                 	12/31/2012

# date 050100002013
Wed May  1 00:00:00 EDT 2013

# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69
Version:              	5.8
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

# yum repolist
Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is registered to Red Hat Subscription Management, but is not receiving updates. You can use subscription-manager to assign subscriptions.

*** WARNING ***
The subscription for following product(s) has expired:
  - Red Hat Beta
  - Red Hat Enterprise Linux Server
You no longer have access to the repositories that provide these products.  It is important that you apply an active subscription in order to resume access to security and other critical updates. If you don't have other active subscriptions, you can renew the expired subscription.  
This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
epel                                                  | 3.4 kB     00:00     
repoid                        repo name                            status
epel         Extra Packages for Enterprise Linux 5 -x86_64          7,107
repolist: 7,107

Moving bug to VERIFIED
Comment 6 errata-xmlrpc 2013-01-07 22:56:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.