Bug 837136 - Promotions -> Products -> Packages list spins and never renders list of packages
Promotions -> Products -> Packages list spins and never renders list of packages
Status: CLOSED UPSTREAM
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 18:25 EDT by Mike McCune
Modified: 2014-09-18 11:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 10:14:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2012-07-02 18:25:30 EDT
On Firefox 3.6 if you try to view the list of packages in a Product in the promotions screen you will just see the spinner and never the entire list of packages in the product.

This was seen at the Summmit 2012.
Comment 2 Justin Sherrill 2012-07-02 18:28:01 EDT
Note this was also seen on firefox 10 and chrome 19 (with 50% reproduceability).  The key here seems to be having a large repo (3-6K) packages.
Comment 3 Justin Sherrill 2012-07-05 10:13:28 EDT
So I think this has less to do with the browser and more to do with the speed of the server.  If the contents are returned too quickly, that is they are returned before the slide event is finished , the problem can occur.  So this should be much more reproducible in production mode. 

I believe I have fixed it, commit incoming.
Comment 4 Justin Sherrill 2012-07-05 11:34:53 EDT
Commited in a3d0f928c389b368c097032bcaf17227de32c92c

At the time of fixing the problem was only reproducible about 5% of the time, so I'm only about 99% sure it is fixed.
Comment 5 Mike McCune 2012-10-24 10:14:33 EDT
closing, upstream

Note You need to log in before you can comment on or make changes to this bug.