Bug 837191 - rhc-port-forward can't work work in windows platform with ruby-1.9.3 and ruby-1.8.7
rhc-port-forward can't work work in windows platform with ruby-1.9.3 and ruby...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 02:30 EDT by Rony Gong
Modified: 2015-05-14 21:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhc-0.95.9-1+
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:43:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rony Gong 2012-07-03 02:30:48 EDT
Description of problem:
this error happens on win7 and winxp with ruby-1.9.3 or ruby1.8.7


Version-Release number of selected component (if applicable):


How reproducible:
always, 


Steps to Reproduce:
1.create a app,embed mysql
2.then do rhc-port-forward -a qphp -d
3.
  
Actual results:
C:\Documents and Settings\openshift>rhc-port-forward -a qphp -d
Password:
Submitting form:
rhlogin: qgong@redhat.com
debug: true
Contacting https://ec2-23-22-197-154.compute-1.amazonaws.com
Checking available ports...
Using 792c48ab555e48c591aaa49af052117d@qphp-qgong3.dev.rhcloud.com...
C:/Ruby193/lib/ruby/gems/1.9.1/gems/rhc-0.95.6/bin/rhc-port-forward:136:in `blo
k (2 levels) in <top (required)>': undefined method `lines' for ["127.0.251.1:3
06", "127.0.251.1:8080"]:Array (NoMethodError)
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:326:in `call'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:326:in `block (3 levels) in exec'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/channel.rb:568:in `call'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/channel.rb:568:in `do_data'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:556:in `channel_data'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:456:in `dispatch_incoming_packets'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:213:in `preprocess'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:197:in `process'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:161:in `block in loop'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:161:in `loop'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:161:in `loop'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/channel.rb:269:in `wait'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh/conn
ction/session.rb:355:in `exec!'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/rhc-0.95.6/bin/rhc-port-forwar
:112:in `block in <top (required)>'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/net-ssh-2.5.2/lib/net/ssh.rb:1
3:in `start'
        from C:/Ruby193/lib/ruby/gems/1.9.1/gems/rhc-0.95.6/bin/rhc-port-forwar
:110:in `<top (required)>'
        from C:/Ruby193/bin/rhc-port-forward:23:in `load'
        from C:/Ruby193/bin/rhc-port-forward:23:in `<main>'


Expected results:
show port



Additional info:
Comment 1 Rony Gong 2012-07-03 03:11:22 EDT
I am using rhc-0.95.6 and devenv_1870, ruby-1.9.3, gem-1.8.23
Comment 2 Rony Gong 2012-07-03 03:20:00 EDT
I am using rhc-0.95.6 and devenv_1870, ruby-1.9.3, gem-1.8.23
Comment 3 Rony Gong 2012-07-03 03:25:11 EDT
All windows platform(win7 and xp) neither ruby-1.9.3 nor 1.8.7 can't do rhc-port-forward.
Comment 4 Clayton Coleman 2012-07-03 13:26:01 EDT
I think this is a dup or already fixed, please check Fabiano
Comment 5 Fabiano Franz 2012-07-09 16:49:41 EDT
Fixed.
Comment 6 joycezhang 2012-07-10 03:13:53 EDT
Verified with build rhc-0.95.11, devnev_1882, ruby-1.9.3/1.8.7 and gem-1.8.24 on Windows7_x64.

The ports are displayed as below:
Binding httpd -> 127.0.254.129:8080...
Binding mysqld -> 127.0.254.129:3306...

So this bug is fixed and can be closed. Thanks.
Comment 7 Levy Costa 2012-07-16 13:37:19 EDT
Hi Everyone!
   I have installed rhc-0.94.8(latest version on http://rubygems.org/gems/rhc), ruby-1.9.3 and gem-1.8.24 on WindowsXP_x32 and a can't do rhc-port-forward(same error).
   How can i update rhc-0.94.8 to rhc-0.95.11? Because when i try to execute the command "gem update rhc" i get a message "Nothing to update".
Comment 8 Xiaoli Tian 2012-07-17 01:26:20 EDT
(In reply to comment #7)
> Hi Everyone!
>    I have installed rhc-0.94.8(latest version on
> http://rubygems.org/gems/rhc), ruby-1.9.3 and gem-1.8.24 on WindowsXP_x32
> and a can't do rhc-port-forward(same error).
>    How can i update rhc-0.94.8 to rhc-0.95.11? Because when i try to execute
> the command "gem update rhc" i get a message "Nothing to update".

Hi, Levy

rhc-0.95.11 is a version which is in developing status, we will release a stable version soon to resolve your problem, please check the update later.

Thanks

Note You need to log in before you can comment on or make changes to this bug.