Bug 837239 - The HP Lights Out Management Console Does Not Work with Iced-Tea
The HP Lights Out Management Console Does Not Work with Iced-Tea
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deepak Bhole
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 05:50 EDT by Emmanuel Seyman
Modified: 2013-05-05 04:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-05 04:22:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firefox output (18.07 KB, application/octet-stream)
2012-07-03 05:50 EDT, Emmanuel Seyman
no flags Details
updated firefox output (15.79 KB, text/plain)
2012-07-09 06:21 EDT, Emmanuel Seyman
no flags Details
Java standard error output (19.67 KB, text/plain)
2012-07-09 06:24 EDT, Emmanuel Seyman
no flags Details

  None (edit)
Description Emmanuel Seyman 2012-07-03 05:50:12 EDT
Created attachment 595918 [details]
firefox output

Description of problem:
I'm unable to start an ILO Remote Console on an HP Server using Fedora's Firefox.

Version-Release number of selected component (if applicable):
icedtea-web-1.2-2.fc17.x86_64
firefox-13.0.1-1.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login to the Integrated Lights-Out 2 (iLO) on a Hewlett-Packard ProLiant server web page using firefox 
2. Click the remote console tab
3. Click the third choice "Remote Console" to launch the java applet based console.
  
Actual results:
A popup window with: Error saying that the applet not initialized.

Expected results:
A popup window running the console on the server.

Additional info:
Attached is firefox's output with ICEDTEAPLUGIN_DEBUG=true LANG=C
Comment 1 Deepak Bhole 2012-07-04 13:46:02 EDT
Hi Emmanuel.

I thought I had seen a bug about this but cannot find it any more :/

Can you please also post the ~/.icedtea/log/* files from the run when ICEDTEAPLUGIN_DEBUG=true?
Comment 2 Emmanuel Seyman 2012-07-04 17:15:56 EDT
(In reply to comment #1)
> 
> I thought I had seen a bug about this but cannot find it any more :/

Bug #497408, perhaps?

> Can you please also post the ~/.icedtea/log/* files from the run when
> ICEDTEAPLUGIN_DEBUG=true?

I won't be back in the office until Monday. I'll post them then.
Comment 3 Deepak Bhole 2012-07-05 15:14:51 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > 
> > I thought I had seen a bug about this but cannot find it any more :/
> 
> Bug #497408, perhaps?
> 

Ah, that must have been it. So looks like you might be encountering a separate issue. I will wait for the logs. Thanks.
Comment 4 Emmanuel Seyman 2012-07-09 06:21:58 EDT
Created attachment 597034 [details]
updated firefox output
Comment 5 Emmanuel Seyman 2012-07-09 06:24:00 EDT
Created attachment 597035 [details]
Java standard error output

$HOME/.icedtea/log/ contains two files : an empty java.stdout and a java.stderr one. Here it is.
Comment 6 Deepak Bhole 2012-07-09 11:23:34 EDT
Thanks! Looks like a CNFE .. can you please run the following and post the output?

for i in `find ~/.icedtea/cache -name "*.jar"`; do 
  unzip -l $i 2>/dev/null | grep -i hp/ilo2/remcons/remcons && echo $i
done


Also, what does this show?

wget --no-check-certificate https://rac-coeos/com/hp/ilo2/remcons/remcons.class
Comment 7 Emmanuel Seyman 2012-07-10 05:41:14 EDT
(In reply to comment #6)
> 
> for i in `find ~/.icedtea/cache -name "*.jar"`; do 
>   unzip -l $i 2>/dev/null | grep -i hp/ilo2/remcons/remcons && echo $i
> done

The only file I have in ~/.icedtea/cache is ~/.icedtea/cache/0/https/rac-coeos/rc175p06.jar.info . It's empty.


> Also, what does this show?
> 
> wget --no-check-certificate
> https://rac-coeos/com/hp/ilo2/remcons/remcons.class

404 Not Found
Comment 8 Deepak Bhole 2012-07-12 12:59:11 EDT
Odd that there is a .info but no jar. What does this show?

wget --no-check-certificate https://rac-coeos//rc175p06.jar
Comment 9 Emmanuel Seyman 2012-07-13 04:09:31 EDT
(In reply to comment #8)
>
> Odd that there is a .info but no jar. What does this show?
> 
> wget --no-check-certificate https://rac-coeos//rc175p06.jar

404 Not Found
Comment 10 Emmanuel Seyman 2012-07-13 05:04:05 EDT
To be more specific, this is the ouput:


--2012-07-13 10:26:26--  https://rac-coeos//rc175p06.cab
Resolving rac-coeos... 192.168.199.1
Connecting to rac-coeos|192.168.199.1|:443... connected.
WARNING: cannot verify rac-coeos's certificate, issued by `/C=US/ST=Texas/L=Houston/O=Hewlett-Packard Company/OU=ISS/CN=ILOCZ20206438':
  Self-signed certificate encountered.
    WARNING: certificate common name `ILOCZ20206438' doesn't match requested host name `rac-coeos'.
HTTP request sent, awaiting response... 404 Not Found
2012-07-13 10:26:30 ERROR 404: Not Found.

Deepak, couldn't the self-signed certificate be the source of the problem?
Comment 11 Deepak Bhole 2012-07-16 13:36:41 EDT
That should've just been a warning though. Can you load/download the jar with firefox?
Comment 12 Emmanuel Seyman 2012-07-17 08:42:48 EDT
(In reply to comment #11)
>
> Can you load/download the jar with firefox?

No, I get the 404 errors even with Firefox.
Comment 13 Deepak Bhole 2012-07-18 14:09:53 EDT
Ah, just noticed that you tried .cab in comment 10 and thereafter.. can you please try the .jar from comment #8?
Comment 14 Emmanuel Seyman 2012-07-19 08:05:00 EDT
Same thing.

Request Error
HTTP/1.1 404 Not Found
Comment 15 Deepak Bhole 2012-07-19 10:19:35 EDT
Hmm, that is really odd. Do you by any chance know where that jar would/should be?
Comment 16 Emmanuel Seyman 2012-07-19 11:26:48 EDT
(In reply to comment #15)
>
> Hmm, that is really odd. Do you by any chance know where that jar
> would/should be?

Not at all. And the only result Google gives me is this bug report. :-(
I'll keep digging.
Comment 17 Emmanuel Seyman 2013-05-05 04:22:40 EDT
Revisiting this bug on Fedora 18 and against ILO4, I'm able to use ILO without problems.

Note You need to log in before you can comment on or make changes to this bug.