Bug 837280 - Proxy Test connection should failed for invalid protocol.
Proxy Test connection should failed for invalid protocol.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Alex Wood
Entitlement Bugs
: QA-Closed
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-07-03 07:12 EDT by spandey
Modified: 2015-04-23 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:56:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error screenshot (50.60 KB, image/png)
2012-07-03 07:12 EDT, spandey
no flags Details

  None (edit)
Description spandey 2012-07-03 07:12:03 EDT
Description of problem:


Version-Release number of selected component (if applicable):


Prerequisites : 
Rhel5.9 with following subscription-manager 
subscription-manager-migration-1.0.7-1.git.10.4c364f3.el5
subscription-manager-gui-1.0.7-1.git.10.4c364f3.el5
subscription-manager-firstboot-1.0.7-1.git.10.4c364f3.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-1.0.7-1.git.10.4c364f3.el5


Steps to repro: 
Launch subscription-manager-gui. 
check HTTP Proxy checkbox 
entry following entry for proxy "testredhat://10.65.193.76:3128" (10.65.193.76:3128 is valid proxy entry).
Test Proxy  connection.

Expected Result : 
Proxy connection failed message should display for “testredhat://10.65.193.76:3128”.

Actual Result : 
Got message “proxy connection succeeded”.
Comment 1 spandey 2012-07-03 07:12:48 EDT
Created attachment 595929 [details]
error screenshot
Comment 2 Alex Wood 2012-08-01 16:40:33 EDT
We actually disregard the scheme entirely when dealing with the proxy entry.  In rhsm.conf we only store the host name and port.  I've written a patch to indicate this action to the user when the user removes focus from the proxy entry field.
Comment 3 Alex Wood 2012-08-03 14:54:56 EDT
commit 995a00f8142c87615b67fe9a50711740d0d238f3
Refs: <origin/awood/837280>, awood/837280, subscription-manager-1.0.11-1-19-g99~
Author:     Alex Wood <awood@redhat.com>
AuthorDate: Wed Aug 1 16:35:14 2012 -0400
Commit:     Alex Wood <awood@redhat.com>
CommitDate: Wed Aug 1 16:36:36 2012 -0400

    837280: Show users that we strip out any scheme given with a proxy.

Available in subscription-manager-1.0.13+
Comment 4 RHEL Product and Program Management 2012-08-09 10:57:21 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 spandey 2012-08-21 05:15:05 EDT
verified using following rpm 

subscription-manager-gui-1.0.14-1.git.2.b6ee391.el5
subscription-manager-migration-data-1.11.2.3-1.git.0.861f9ba.el5
subscription-manager-firstboot-1.0.14-1.git.2.b6ee391.el5
subscription-manager-migration-1.0.14-1.git.2.b6ee391.el5
subscription-manager-1.0.14-1.git.2.b6ee391.el5

working fine 

resolving defect as verified
Comment 8 errata-xmlrpc 2013-01-07 22:56:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.