Bug 837281 - test inversion in ifup-ipv6 script for testing IPV6 global forwarding [NEEDINFO]
test inversion in ifup-ipv6 script for testing IPV6 global forwarding
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.4
All Linux
unspecified Severity low
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 07:14 EDT by Fabien Bataille
Modified: 2014-06-02 09:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:18:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (fbataill)


Attachments (Terms of Use)

  None (edit)
Description Fabien Bataille 2012-07-03 07:14:03 EDT
Description of problem:

Inversion of test in ifup-ipv6 script for testing IPV6 forwarding.
Line 103:
"if [ $ipv6_global_forwarding_current -ne 1 ]; then"
should be replaced by
"if [ $ipv6_global_forwarding_current -eq 1 ]; then"

Line 120:
"if [ $ipv6_global_forwarding_current -ne 0 ]; then"
shoud be replaced by
"if [ $ipv6_global_forwarding_current -eq 0 ]; then"


Version-Release number of selected component (if applicable):
5.4

How reproducible:
Set IPV6 forwarding to 1 (ie: enable it), and do ifup eth0 with eth0 have an IPv6 address.
You will see a message stating:
"Global IPv6 forwarding is disabled in configuration, but not currently disabled in kernel"

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2014-03-07 08:44:34 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:18:53 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.