Bug 837336 - [RFE] Create API Guide for Cloud Engine
[RFE] Create API Guide for Cloud Engine
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: Documentation (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Dan Macpherson
Rehana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 10:02 EDT by james labocki
Modified: 2012-12-10 16:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:54:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james labocki 2012-07-03 10:02:02 EDT
This is a request to create a API guide for Cloud Engine similar to what is available for Red Hat Network Satellite today. 

Example API Guide for Satellite - http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/5.4.1/html/API_Overview/index.html

System Engine API upstream documentation can be found here - https://fedorahosted.org/katello/wiki/ApiDocLatest

Cloud Engine API upstream documentation can be found here - 
https://www.aeolusproject.org/redmine/projects/aeolus/wiki/Conductor_API
Comment 6 Dan Macpherson 2012-10-31 22:40:14 EDT
CloudForms 1.1 API Guide draft available:
http://documentation-devel.engineering.redhat.com/docs/en-US/CloudForms/1.1/html/API_Guide/index.html

Since this bug is a tracker bug, I'm switching to RELEASE_PENDING. If you find any problems with the guide, please file a new bug.
Comment 7 Lana Brindley 2012-12-10 16:54:02 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.