Bug 837341 - [xfs/xfstests 219] Not all quotas are reported by repquota on XFS
[xfs/xfstests 219] Not all quotas are reported by repquota on XFS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: quota (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 10:15 EDT by Petr Pisar
Modified: 2012-07-14 17:54 EDT (History)
5 users (show)

See Also:
Fixed In Version: quota-4.00-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 836200
Environment:
Last Closed: 2012-07-14 17:54:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2012-07-03 10:15:52 EDT
+++ This bug was initially created as a clone of Bug #836200 +++

Description of problem:
Running xfstests test case no. 219, the test fails with 'Bad number of inodes used (type=g)'. This happens because the repquota does not report any group quotas (no #$gid line in the output of repquota, it contains #0 line only).

Version-Release number of selected component (if applicable):
kernel-3.3.0-0.14.el7.x86_64
xfsprogs-3.1.8-1.el7.x86_64
quota-4.00-3.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run the xfstests test case no. 219
  
Actual results:
The test failure because the repquota does not report the group quota.

Expected results:
The test passes.

Additional info:
This does not happen with xfs on rhel6 nor with ext4 on rhel7.

--- Additional comment from esandeen@redhat.com on 2012-06-28 17:59:07 GMT ---

Newer quota repquota isn't reporting it - I guess this is likely to be a quota issue?  quota 3.17 is ok, 4.0 is not.  Output diff:

[root@inode xfstests-dev]# /bin/mount -t xfs -o grpquota,context=system_u:object_r:nfs_t:s0 /dev/sdb6 /mnt/scratch

3.7:

[root@inode xfstests-dev]# repquota -g -n /mnt/scratch/
*** Report for group quotas on device /dev/sdb6
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
Group           used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
#0        --       0       0       0              3     0     0       
#2        --     144       0       0              3     0     0       


4.0:

[root@inode xfstests-dev]# repquota.new -g -n /mnt/scratch/
*** Report for group quotas on device /dev/sdb6
Block grace time: 7days; Inode grace time: 7days
                        Block limits                File limits
Group           used    soft    hard  grace    used  soft  hard  grace
----------------------------------------------------------------------
#0        --       0       0       0              3     0     0

--- Additional comment from esandeen@redhat.com on 2012-06-28 20:17:54 GMT ---

Looks like this is needed:

From: Jan Kara <jack@suse.cz>
Date: Fri, 8 Jun 2012 09:11:20 +0000 (+0200)
Subject: repquota: Fix reporting for XFS
X-Git-Url: http://linuxquota.git.sourceforge.net/git/gitweb.cgi?p=linuxquota%2Flinuxquota;a=commitdiff_plain;h=6ba6546dd167297cb9ed69d0257ee245b0faea47

repquota: Fix reporting for XFS

Conversion to generic quota scanning introduced a bug for XFS where we
stopped scanning after quotactl reported first error. quotactl for XFS
however reports ENOENT when it has nothing to report for a particular user
/ group and we shouldn't stop scanning after that. We tried to test for this
but the test was wrong. Fix it.

Signed-off-by: Jan Kara <jack@suse.cz>
-------

F18--17 are affected (since quota-4.00).
Comment 1 Fedora Update System 2012-07-03 10:53:52 EDT
quota-4.00-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/quota-4.00-4.fc17
Comment 2 Fedora Update System 2012-07-05 19:40:04 EDT
Package quota-4.00-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing quota-4.00-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10292/quota-4.00-4.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-07-14 17:54:50 EDT
quota-4.00-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.